Dodge Durango Forum banner

1 - 20 of 24 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
My Uconnect just update to 18.11.07, I can't find anything on this version anywhere. And I don't notice anything different. I have a 2014 Durango RT.
 

·
Registered
Joined
·
3 Posts
My Uconnect just update to 18.11.07, I can't find anything on this version anywhere. And I don't notice anything different. I have a 2014 Durango RT.
Same here. I have a 2015 Grand Cherokee. Haven't noticed anything different but very strange there is NO mention ANYWHERE on the internet about this version or what changed.
 

·
Registered
Joined
·
3 Posts
Own it's own? I thought you had to manually update the Uconnect system?
Not completely in it's own. My radio said their was an update available and asked if I wanted to install. I clicked yes and let it install... But no changes and nothing online about the update.
 

·
Registered
Joined
·
40 Posts
Just happened on my 2006 Durango as well. Give me a warning that it was time to update you connect, it updated in five minutes. There is nothing specific about new software other than maps weren’t updated.
 

·
Registered
Joined
·
3 Posts
I just got an email today from Jeep/Mopar to let me know that the new SW update was coming (6 days after it already came mind you)...still, no mention of what changed.
 

·
Registered
Joined
·
113 Posts
I got my update today, and an email, too. The "about update" page says navigation wasn't affected but important updates were made. The pop-up screen after I started driving said that programmed stations and paired phones would have to be re-done, but they all seem OK.

No obvious changes yet.
 

·
Registered
Joined
·
72 Posts
The update failed on both my wife's '17 Durango R/T and my '15 Challenger SRT.

The Durango at least usually has a 3G connection to Uconnect through Sprint. My Challenger isn't driven very much (only about 6,000 miles this year) and rarely has more than a 1G connection.
 

·
Registered
Joined
·
44 Posts
I wonder if it has to do with the screen blackout issues? I am waiting for a new radio on my 2019. It started blacking out within about the first 300 miles I put on it.
 

·
Registered
Joined
·
299 Posts
That's weird, I accepted an update over the air 2 weeks ago and now checked online using my vin saying I now have the 18.45.1 update to download.
 

·
Registered
Joined
·
299 Posts
That's weird, I accepted an update over the air 2 weeks ago and now checked online using my vin saying I now have the 18.45.1 update to download.
 

·
Registered
Joined
·
535 Posts
That's weird, I accepted an update over the air 2 weeks ago and now checked online using my vin saying I now have the 18.45.1 update to download.
I applied that one to my Hellcat & it trashed the am/fm radio - all I get is static now. It has happeded to others as well, I'd skip that update if I were you !
 

·
Registered
Joined
·
72 Posts
I downloaded 18.45.1 today and successfully updated the Uconnect system in my wife's '17 Durango R/T. Everything from the radio, to the clock, to NAV, to the phone work just fine.

The only issue was not being able to unzip the download on my wife's laptop (Windows 10) using the normal unzip tool. I've read that people have had no issues when using other unzipping software. My solution was to download the update on my MacBook and then copy the files onto a FAT 32 USB drive.
 

·
Registered
Joined
·
299 Posts
Just update with no issues, took 20 minutes and loaded 15 units. Unzipped with 7-Zip.
 

·
Registered
Joined
·
83 Posts
Doing a little research (mine updated today) it is for a GPS update. Can find more info over at the various Jeep forums.
 

·
Registered
Joined
·
68 Posts
My wife drives a 2017 Citadel V8. On the same day I received an FCA email asking me to go online and download the latest Uconnect update, my wife showed me a message on the Uconnect screen prompting her to accept an update. I thought the car had downloaded the required update OTA on its own, so I clicked accept and let it sit for an hour with the ignition off. Then I followed the link in the email and downloaded the 18.45.01 zip file. When I turned on the car to check the system version, I noticed it had only updated itself to 18.43, which is not even among the older versions addressed in the 18.45 install instructions. I went ahead and updated the car to 18.45.01 anyway, through the USB port. I had to keep the car running for about 25 minutes for the install to finish. With 18.45.01, I haven't noticed any difference in the Uconnect interface or functionality. However, my wife complained about hearing thumping noises from the left front speaker even when the radio is muted. I will have to drive it myself to verify her claim.
 

·
Registered
Joined
·
2 Posts
My wife drives a 2017 Citadel V8. On the same day I received an FCA email asking me to go online and download the latest Uconnect update, my wife showed me a message on the Uconnect screen prompting her to accept an update. I thought the car had downloaded the required update OTA on its own, so I clicked accept and let it sit for an hour with the ignition off. Then I followed the link in the email and downloaded the 18.45.01 zip file. When I turned on the car to check the system version, I noticed it had only updated itself to 18.43, which is not even among the older versions addressed in the 18.45 install instructions. I went ahead and updated the car to 18.45.01 anyway, through the USB port. I had to keep the car running for about 25 minutes for the install to finish. With 18.45.01, I haven't noticed any difference in the Uconnect interface or functionality. However, my wife complained about hearing thumping noises from the left front speaker even when the radio is muted. I will have to drive it myself to verify her claim.
Attach a photo please
 
1 - 20 of 24 Posts
Top