Dodge Durango Forum banner
1 - 13 of 13 Posts

·
Premium Member
Joined
·
2,590 Posts
Discussion Starter · #1 · (Edited)
I decided to call Uconnect from the app in my truck this morning. The reason is to complain about no weather and find out what their issue is.
Yes I know I would have been asking for the impossible but hey I'll try anyway.
When I opened the assist app, you have a choice of Dodge Support, Uconnect Support and Sirius Guardian Support (there was a 4th choice but I forget what it was)
I would choose Uconnect and when I got connected it said Sirius Guardian and when the rep answered, she was Sirius Guardian and had no idea about Uconnect and said to call them. I thought I may have pressed the wrong button so I tried again. Again I got Sirius Guardian and I hung up.

Either this is a bug in the Uconnect system or Dodge decided to merge Uconnect with Sirius but forgot to tell Sirius Guardian.

@DodgeCares your systems are useless and when we need support we cannot get it! @DodgeCares can you answer as to why various departments (Uconnect, Sirius Guardian etc) have no idea about how things are supposed to work and why do they always blame the end user?
 

·
Premium Member
Joined
·
2,590 Posts
Discussion Starter · #2 ·
Also when on mopar.com and you click chat you get the following error. The reason is , commercial-vehicles.custhelp.com does not exist in DNS. How laughable does Dodge want to be thought of?

Hmm. We’re having trouble finding that site.

We can’t connect to the server at commercial-vehicles.custhelp.com.

If that address is correct, here are three other things you can try:

Try again later.
Check your network connection.
If you are connected but behind a firewall, check that Firefox has permission to access the Web.
 

·
Premium Member
Joined
·
2,590 Posts
Discussion Starter · #3 ·
what a joke Dodge is
 

·
Premium Member
Joined
·
2,590 Posts
Discussion Starter · #6 ·
firmware version 17.99 fixed the weather issue 75 percent.
Now maybe it fails once every 60 days and usually is fine the next day.
A few weeks back it was broken for a few weeks. (I suppose satellite issues)
TomTom is either garbage or Dodge is paying for the bottom of the barrel satellite access.
Take your pick because not matter what, it's Dodge's fault!
 

·
Registered
Joined
·
4 Posts
firmware version 17.99 fixed the weather issue 75 percent.
Now maybe it fails once every 60 days and usually is fine the next day.
A few weeks back it was broken for a few weeks. (I suppose satellite issues)
TomTom is either garbage or Dodge is paying for the bottom of the barrel satellite access.
Take your pick because not matter what, it's Dodge's fault!
I messaged @DodgeCares. I'm trying to get them to send me the 17.99 update.
 

·
Registered
Durango Hellcat
Joined
·
316 Posts
I messaged @DodgeCares. I'm trying to get them to send me the 17.99 update.
Yeah they won’t.. you can get 17.89 (available for download on this forum if you don’t want to bother with the dealership) and then contact Uconnect so they can trigger the availability of the latest firmware for you. That’s what it took for me to finally get the update after 6 months.
 

·
Registered
Durango Hellcat
Joined
·
316 Posts
My question is why isn't this available for download on the friggin Dodge web site? I'll have to waste a day off work to go to the dealer just for this kind of nonsense I could do at home? Sad.
I wish I knew. The entire process was awful and I had 2 escalations with Uconnect and 6 dealer appointments over a 6 month period trying to get the latest version on my radio. The time next I spend 100K+ on a vehicle Dodge isn’t going to be top of my list after this experience.
 

·
Registered
Joined
·
4 Posts
I just bought a 2022 RT a month and a half ago and the Sirius Guardian app (uconnect) doesn't work at all. Vehicle location doesn't work either. I tried the SOS button like sirius said and they said since it doesn't work then off to the dealership. The activate subscription button in the stereo only gets a message that "network unavailable", the assist button only gets a "loading" message and then nothing. I tried messaging @DodgeCares but I guess I haven't been on here long enough to do that so I'm just adding my 2 cents.
Of the month and a half of ownership, 3 weeks at dealership.
I wish someone would get this figured out.
 
1 - 13 of 13 Posts
Top