Dodge Durango Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Didn't find anything similar to my problem. So I figured I'd post. I've got a 2002 SLT plus with the 4.7 and dual climate. And for the love of God I cannot get this truck to blow cold air. I recently replaced the compressor, and recharged it. But I've narrowed it down to the snowflake. For some reason my snowflake doesn't turn on the Compressor. But I know the Compressor works because I've used it in defrost just fine. If there's any info I'm missing. Please feel free to ask.
 

·
Super Moderator
Joined
·
12,775 Posts
are you sure the compressor works normally in defrost but doesn't work at all in any other mode?
that's important to find out..
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
are you sure the compressor works normally in defrost but doesn't work at all in any other mode?
that's important to find out..
I mean. I've yet to see it engage when it's not on defrost. And my snowflake button doesn't light up when I hit it with the air on
 

·
Super Moderator
Joined
·
12,775 Posts
hm.. I forget how the snowflake button works on an 02, and the FSM isn't much help :(
 

·
Registered
Joined
·
6 Posts
Discussion Starter #6
Would it help to mention my rear defroster is disconnected from the back window, so my rear defrost button flashes?
 

·
Registered
2003 Atlantic Blue Durango R/T
Joined
·
25 Posts
When you are driving with just the front AC zone on, does it get cooler ???
 

·
Registered
Joined
·
55 Posts
Could be an issue with the control module.

Sent from my Pixel 3 XL using Tapatalk
 

·
Registered
Joined
·
6 Posts
Discussion Starter #10
When you are driving with just the front AC zone on, does it get cooler ???
That's the thing. I can't seem to get my truck to even recognize that I want the AC on. I push the snowflake, but the light doesn't turn on, Nor does the compressor.

Could be an issue with the control module.

Sent from my Pixel 3 XL using Tapatalk
If you're referring to the AC control module, I've already replaced it with a working unit on eBay.
 
1 - 11 of 11 Posts
Top