Dodge Durango Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
well i tried to replace the air intake on my perfectly fine just passed inspection 5.9 dodge durango and some how ended up getting 4 dtc's the only one i can remember is p1495 for a ldp solenoid circuit problem but during a test run my suv couldn't pick a position for the transmission (it kept cycling though p n r d 2 1) so i disconnected the negative battery terminal for a couple minutes then put it back on and turned my engine back on and the battery which fixed that. i took it for a small test drive to see i i could notice anything, the suv was having trouble shifting out of 2nd to 3rd then the radio started cutting out and the check gauges light came on then the battery gauge died so i parked it and turned it off but when i tried to restart it it only clicked continuously until i switched the ignition back to off. im just out of town working right now but need a place to start my repair because of right now i am carless until i fix the problem which arose from installing the air intake and relocation of the cruise control (placed on a smaller bracket). any help would be much appreciated.
 

·
Premium Member
Joined
·
473 Posts
Sounds like you have a bad connection somewhere. Clean and redo the battery connections. What do you mean by replacing air intake? What brand intake did you put on? any pictures might help. LDP is leak detection pump and is part of the emissions package. Low voltage will cause it to set a code so I am back to a bad connection that you may have created when working on the air intake.
 

·
Premium Member
Joined
·
5,764 Posts
Check the connection into the PDC, power distribution center, fuse box. As for the intake change, was it a new system you added?(removed the Hemi hat and tubing?)
 

·
Administrator
Joined
·
5,612 Posts
for an '01 5.9, a new air intake should have no issues. you can run without anything on top of the TB. Somewhere you disconnected a wire. there is also a tube from the Airhat that could be disconnected. check for that, but it shouldn't affect electrical. could the battery be bad and it just coincided with the addition of the CAI.
 
1 - 4 of 4 Posts
Top