Dodge Durango Forum banner
1 - 20 of 42 Posts

·
Registered
Joined
·
41 Posts
Discussion Starter · #1 ·
Installed my RIPP Supercharger kit recently and gave it a quick test. not really happy with these numbers. i've also noticed the Boost gauge does not exceed 4psi. I tried both RIPP Tune and a Custom Tune. looking forward to read your suggestions :confused:

Test Race (vs Jeep SRT)

0-60 Time


1/4 Mile Time
 

·
Registered
Joined
·
5,394 Posts
Sounds like you have a big air leak somewhere in the intake system.
Might want to try a boost leak tester and see if the intake system holds pressure.
 

·
Premium Member
Joined
·
28,308 Posts
That and it needs better Tuning
STEVE
 

·
Registered
Joined
·
441 Posts
I have heard tuning issues with the Ripps. But those numbers are basically stock numbers.
 

·
Premium Member
Joined
·
28,308 Posts
They are not stock numbers whatsoever. I dont care what your on board stuff is telling you, you are not running that time in 1/4 mile with your ride on a track.
he has minimal gains for sure and you can hear its not building boost or not getting enough fuel
I would have it DYNO Tuned to get it right.
STEVE
 

·
Registered
Joined
·
41 Posts
Discussion Starter · #6 ·
is there an easier way to find leaks other than tester kit ? something like spray ?
 

·
Registered
Joined
·
41 Posts
Discussion Starter · #7 ·
One more thing, how to remove the transfer case ? we have 4 dynos in twon, all of them are single runners
 

·
Registered
Joined
·
441 Posts
They are not stock numbers whatsoever. I dont care what your on board stuff is telling you, you are not running that time in 1/4 mile with your ride on a track.
he has minimal gains for sure and you can hear its not building boost or not getting enough fuel
I would have it DYNO Tuned to get it right.
STEVE

No not 1/4 mile time but 0-60 is very close to stock. 1/4 should be in the low to mid 13's with this setup and 0-60 should be way lower then that. Like you said it seems like a boost issue where it isn't building it.
 

·
Registered
Joined
·
441 Posts
One more thing, how to remove the transfer case ? we have 4 dynos in twon, all of them are single runners
You could get a Tazer and turn it to RWD.
 

·
Registered
Joined
·
41 Posts
Discussion Starter · #10 ·

·
Registered
Joined
·
47 Posts
I have heard tuning issues with the Ripps. But those numbers are basically stock numbers.
Stock numbers are 0 to 60 in 6.6 seconds and a 15.0 flat in the 1/4 mile. It's almost a full second faster than stock, but those numbers are still an an improvement. They could be better. This Durango with a Whipple does the 1/4 in 13.2 at 104 mph which is about 4.6 to 0 to 60, so your Durango should equal or get close to those numbers.

 

Attachments

·
Registered
Joined
·
441 Posts
I am just saying from my own car basically stock and running 6 flat and also at times I have had low 5's on a really good cold day.
 

·
Registered
Joined
·
41 Posts
Discussion Starter · #13 ·
Looks like i have two issues, my Tuner confirmed that the engine belt slips, and cannot be tightened any further. and RIPP is suggesting that my headers is causing huge boost loose. and wants me to purchase a bigger pulley.
 

·
Registered
Joined
·
2,484 Posts
Looks like i have two issues, my Tuner confirmed that the engine belt slips, and cannot be tightened any further. and RIPP is suggesting that my headers is causing huge boost loose. and wants me to purchase a bigger pulley.
Headers don't cause you to loose boost...

Sent from my SM-G935T using Tapatalk
 

·
Premium Member
Joined
·
28,308 Posts
Yeah that is not the answer...
I AM CALLING BAD TUNER
PAY either HEMIFEVER OR JOHAN MENGS ( DIABLOTOONA) A FEE TO REVIEW AN EMAIL LOG YOU SEND THEM OF HOW ITS RUNNING
I'LL bet they can find something just looking at a log and possibly adjust tune via email (not best way but not much choice)
Good Luck
 

·
Registered
Joined
·
41 Posts
Discussion Starter · #16 ·
Yeah that is not the answer...
I AM CALLING BAD TUNER
PAY either HEMIFEVER OR JOHAN MENGS ( DIABLOTOONA) A FEE TO REVIEW AN EMAIL LOG YOU SEND THEM OF HOW ITS RUNNING
I'LL bet they can find something just looking at a log and possibly adjust tune via email (not best way but not much choice)
Good Luck
Yup i worked with Johan before he is excellent. i'll drop him a message
 

·
Registered
Joined
·
1,114 Posts
Stock numbers are 0 to 60 in 6.6 seconds and a 15.0 flat in the 1/4 mile. It's almost a full second faster than stock, but those numbers are still an an improvement. They could be better. This Durango with a Whipple does the 1/4 in 13.2 at 104 mph which is about 4.6 to 0 to 60, so your Durango should equal or get close to those numbers.

Hey, I know that Durango! ;) :cool:

Looks like i have two issues, my Tuner confirmed that the engine belt slips, and cannot be tightened any further. and RIPP is suggesting that my headers is causing huge boost loose. and wants me to purchase a bigger pulley.
Yeah that is not the answer...
Headers causing you to lose boost? I have long tubes and I see 8psi at WOT and that's about what Whipple says I should be seeing with the pulley they provide. Something sounds suspicious to me...
 

·
Registered
Joined
·
41 Posts
Discussion Starter · #19 ·
Tested the leaks last week there was nothing.
Finally bought a smaller pulley from RIPP (3.25") instead of the original (4"), also spoke with Johan he is waiting me to install the pulley first.
 

·
Registered
Joined
·
5,394 Posts
Excellent, you're narrowing it down.
I do remember installing a whipple on a marine GM big block and after installing headers we too lost boost.
We had to install a smaller pulley to get the boost back up, but the upside was the engine made more power and the boat gained speed over the stock exhaust manifolds.
So if the belt isn't slipping you will be good to go soon.
 
1 - 20 of 42 Posts
Top