Dodge Durango Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
This is a 2 part thread and I would appreciate anyone's help and advice. While driving to work the check engine light on my '15 Limited came on after only driving a couple of blocks. The light is still on, but now when I press the remote start button on my key, the truck starts and runs for about 30 seconds and then shuts off. I get a message stating remote start was deactivated. Would disconnecting the battery solve this by "resetting" the computer or is it something a mechanic needs to do with a code reader? Has anyone else had this issue?
Part 2: I just received a post card from FCA about an urgent safety recall to reprogram powertrain control module- U65/NHTSA 18V-332. Is this recall related to the cruise control issue or is it something else? I looked on the NHTSA page and Googled the recall number but couldn't find anything.
Thanks all for your time and replies.
Merry Christmas/ Happy New Years to all....
 

·
Registered
Joined
·
1 Posts
bro had that on my 16 limited but changing the fob battery solves also if any more lights come on its the electronic harness located at bottom front bumper
 
1 - 3 of 3 Posts
About this Discussion
2 Replies
2 Participants
DestroyerJay
Dodge Durango Forum
Welcome to the best Dodge Durango Forum around, where you can find a great Dodge Durango Wiki and discuss the reliability of the different trim levels including the GT and SRT!
Full Forum Listing
Top