Dodge Durango Forum banner
1 - 7 of 7 Posts

·
Registered
2014 Durango Limited 3.6L AWD
Joined
·
149 Posts
Discussion Starter · #1 ·
The two USB ports for my rear seats haven’t been working for a while. These are the two ports located on the back of the center console. Everything else on the console is working fine- rear heated seats, air vents, lights inside the console, etc. The blue ambient lighting inside the ports is even working. I checked all of the fuses and they seem fine to me. Is there anything I’m missing?
 

·
Registered
Joined
·
5 Posts
The two USB ports for my rear seats haven’t been working for a while. These are the two ports located on the back of the center console. Everything else on the console is working fine- rear heated seats, air vents, lights inside the console, etc. The blue ambient lighting inside the ports is even working. I checked all of the fuses and they seem fine to me. Is there anything I’m missing?
Did you ever figure anything out on this? I have the same problem.
 

·
Registered
Joined
·
89 Posts
The rear ports will only charge a device, there isnt a connection to the radio...
 

·
Registered
Joined
·
402 Posts
I realize that. My ports do not charge. They are dead.
I just checked the 2014 wiring diagrams, and do not see the rear USB ports on any diagram. Did anyone find them on a wiring diagram, and if so, which one? I see MEDIA PORT apparently has the front USB ports.
 

·
Registered
Joined
·
5 Posts
I just checked the 2014 wiring diagrams, and do not see the rear USB ports on any diagram. Did anyone find them on a wiring diagram, and if so, which one? I see MEDIA PORT apparently has the front USB ports.
My mistake. I have a 2019 citadel. I misread the year on the original post. Sorry for the misdirection.
 

·
Registered
Joined
·
89 Posts
Try checking fuses F66 and F67 under the hood. According to the manual, they have something to do with the USB ports
 
1 - 7 of 7 Posts
Top