Dodge Durango Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
99 durango 4.7 4x4
Hello
I am the not so proud owner of a dodge lemon
I got this truck knowing it has issues the trans was cooked form the lady driveing in limp home mode..2nd gear..and manual shifting ..lots of metal.
trans was replaced but now to the real issue no bus error p1698 she says {she changed the tcm and had it flashed by autozone}
Its a junkyard tcm so not going to trust that..



I have checked all grounds,bus wires and bus voltage 2.63v..
Mabey tcm is crap or not flashed right or something.. I love the look of these beasts but hate the dumb wiring
Im not a mopar guy so ????????
 

·
Administrator
Joined
·
28,307 Posts
99 Durango never had a 4.7 so make sure she put in right TCM
Your only choices are 5.2 or 5.9
4.7 came out in 2000
STEVE
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
Sorry 2000 kinda odd truck a lot of the dash panels and misc parts say 99 but the mfg tag says 10/99 but the title says 2000 and all vin match 2000
 

·
Administrator
Joined
·
28,307 Posts
Ok there are 2 computers in a 2K d
Regular PCM and Transmission module TCM (mounted behind passenger headlight)
Describe what is happennoing ...does it start? , DOes it move at all?
STEVE
 

·
Registered
Joined
·
7 Posts
Discussion Starter #5
O yes I'm sorry kinda not thinking there yes you got computer locations right it runs great but takes off and stays in 2nd gear the drive selector lights all light up
 

·
Administrator
Joined
·
28,307 Posts
You can pick up another TCM from Scrap yard for about 35-45 $ Its plug and play
Also make sure whomever put fluid filters in trans did them right. That trans is pretty stout and should be fie
STEVE
 

·
Administrator
Joined
·
28,307 Posts
Yes you can get it from a 2000, 2001 and very early 02 Late 02's were integrated into PCM and wont be there.
STEVE
 

·
Registered
Joined
·
7 Posts
Discussion Starter #11
well its not the tcm got 1 from juck yard no go my friend has 2001 durango we tossed my tcm in his truck worked fine.
..tried his in mine no luck.
..I read a thread that someone had dirty ignition module but not sure what part that is or what it even looks like
 

·
Super Moderator
Joined
·
12,867 Posts
I'd look for wiring harness damage. Sounds like something might be shorted.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #13
Ya I thought that too but my harness has no breaks or burns and all wires test OK from dash cluster to TCM/PCM thinking its dealer time or scrap depending on cost
 
1 - 13 of 13 Posts
Top