Dodge Durango Forum banner
1601 - 1620 of 1650 Posts

·
Registered
Joined
·
166 Posts
Just checked on mine a minute ago. Ordered mine on 3/23/22, still shows in "D". I have a DDSRT with all the bells and whistles so hopefully within the next couple of weeks like my letter stated.
 

·
Premium Member
Joined
·
720 Posts
Just checked on mine a minute ago. Ordered mine on 3/23/22, still shows in "D". I have a DDSRT with all the bells and whistles so hopefully within the next couple of weeks like my letter stated.
wvhemis, yours should be rolling soon now that the plant is back up and running.
 

·
Premium Member
Joined
·
720 Posts
I know right?? I ordered on 3/23/22 and I am still stuck in "D". I hope shipping is not too slow. They do go by rail first and then by truck.
it took mine close to 3 weeks from shipped to actually showing up at the dealer. and that was back in early December. it gets shipped by rail to the nearest rail yard and then it has to be unloaded and put on a carrier to get to the dealership. that last part is usually the hold up. it may sit at the rail yard for a while until its picked up and transported.
 
  • Like
Reactions: wvhemis

·
Registered
Joined
·
32 Posts
it took mine close to 3 weeks from shipped to actually showing up at the dealer. and that was back in early December. it gets shipped by rail to the nearest rail yard and then it has to be unloaded and put on a carrier to get to the dealership. that last part is usually the hold up. it may sit at the rail yard for a while until its picked up and transported.
Yep - not my first rodeo….. just sit back and wait!
 

·
Premium Member
Joined
·
720 Posts
Congratulations! Interesting this was in production for so long - there must have been an issue during QA - call your dealer and see if you can get the code schedule for your build……
a QA issue is certainly possible. but notice the In Production date is May 31. I've heard that was the date the plant came back online. wouldn't surprise me if they pressed 'Go' on a whole bunch of orders they were now ready to build and it just took a while to get the large amount actually completed.
 
  • Like
Reactions: wvhemis

·
Registered
Joined
·
32 Posts
a QA issue is certainly possible. but notice the In Production date is May 31. I've heard that was the date the plant came back online. wouldn't surprise me if they pressed 'Go' on a whole bunch of orders they were now ready to build and it just took a while to get the large amount actually completed.
a QA issue is certainly possible. but notice the In Production date is May 31. I've heard that was the date the plant came back online. wouldn't surprise me if they pressed 'Go' on a whole bunch of orders they were now ready to build and it just took a while to get the large amount actually completed.
a QA issue is certainly possible. but notice the In Production date is May 31. I've heard that was the date the plant came back online. wouldn't surprise me if they pressed 'Go' on a whole bunch of orders they were now ready to build and it just took a while to get the large amount actually completed.
a QA issue is certainly possible. but notice the In Production date is May 31. I've heard that was the date the plant came back online. wouldn't surprise me if they pressed 'Go' on a whole bunch of orders they were now ready to build and it just took a while to get the large amount actually completed.
That’s entirely possible…..but generally takes 2-3 days Frame-Paint-Trim QA in any event they are built and ready to ship!
 
1601 - 1620 of 1650 Posts
Top