Dodge Durango Forum banner

1 - 20 of 40 Posts

·
Registered
Joined
·
736 Posts
Discussion Starter #1
Hey all you guys with the Uconnect 730n RHR. There was a firmware update to 2.700 last week. I cannot find any info as far as what the update does, as of yet. Just wanted to keep you informed.

Download Now | MyGig RHR 2.700 Software Update
 

·
Registered
Joined
·
736 Posts
Discussion Starter #2
Ok So I did the update on my drive in this morning. The only thing different I can tell is it seems I am now getting song info when streaming from bluetooth. Still no voice text function. Visually everything is still the same, and unfortunately still blue. Will keep an eye out for release notes and play with it more later.
 

·
Registered
Joined
·
736 Posts
Discussion Starter #3
Still waiting to see if there are any update notes. In the meantime I emailed gracenotes to see if there is a way to subscribe to updates or get alerts as to when there updates since uconnects website always tells us we are up to date. Will keep you all posted as I find out more info.

One other quick note. My Low deep bass seems to boom a bit more. I noticed my windows were actually vibrating during one song. Mid bass... still could use some help.
 

·
Registered
Joined
·
17 Posts
I updated. It went smoothly. I was on 2.1 so I hope to see some improvements. Nothing obvious yet but I haven't much chance to explore.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
11 Posts
i had issues with my bluetooth, USB, Navigation working. i replaced the hard drive and my bluetooth & GPS came back working. But my USB has only power and the unit doesn't pick up my phone plugged in, or my music on the USB..............i'm sure this update couldn't hurt it, but Does anyone know if this may fix my problem with USB getting to work again???? Or what i could do to get my USB to recognize again???
 

·
Registered
Joined
·
736 Posts
Discussion Starter #7
i had issues with my bluetooth, USB, Navigation working. i replaced the hard drive and my bluetooth & GPS came back working. But my USB has only power and the unit doesn't pick up my phone plugged in, or my music on the USB..............i'm sure this update couldn't hurt it, but Does anyone know if this may fix my problem with USB getting to work again???? Or what i could do to get my USB to recognize again???
I always connect my I6 via bluetooth. I'll try connecting via usb later and will let you know if it works.
 

·
Registered
Joined
·
17 Posts
Do you connect via the plug on the radio or the plug in the arm rest? I use the Arm rest and it usually connects fine. Sometimes I have to turn the radio off for a few seconds and the back on to get it to recognize my iPhone. Then it can play music. I control the songs via the phone as the unit controls seem to lag. Hoping this new update improves that.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
736 Posts
Discussion Starter #9

·
Registered
Joined
·
11 Posts
Primarely i use the USB by the head unit with my flashdrive, and the Armrest port is my charging station. Neither one picks up phones(i6, or S7), but can still charge......i've tried switching them around and still no result.... i will try the powering on/off method when i get back to it.
 

·
Registered
Joined
·
736 Posts
Discussion Starter #11
Primarely i use the USB by the head unit with my flashdrive, and the Armrest port is my charging station. Neither one picks up phones(i6, or S7), but can still charge......i've tried switching them around and still no result.... i will try the powering on/off method when i get back to it.
I can tell you the one time my wife plugged into the arm rest port with her I6 it connected to her phone and we didnt realize it till her music started playing.
 

·
Registered
Joined
·
736 Posts
Discussion Starter #12


Ok so on my way home from work I plugged the phone into the head unit USB and turned off Bluetooth. Everything worked fine. I was streaming pandora at the time.

Maybe try a different lighting cable. Make sure it's apple certified.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
736 Posts
Discussion Starter #14

·
Registered
Joined
·
736 Posts
Discussion Starter #17
How do you get the update from the internet to your radio? Someone help me understand...
I burned the ISO file to a dvd-r. Make sure it is a single layer and not a dvd-rw. I had to burn twice because the first one didnt seem to work. Also if you are doing both the radio and gracenotes updates, burn them on to separate discs. Takes about 20-30 minutes to do each update. I usually do it while driving to work since the vehicle needs to be running. If you do it while driving beaware that some systems like cruise control may turn off and on during the process.
 

·
Registered
Joined
·
48 Posts
How would one go about putting it on a flash drive? I’ve read on the site that CD is recommended. I have easier access to my flash drives then CD to burn. But I’ll get one if the flash drive method is too hard.
 

·
Registered
Joined
·
39 Posts
No luck here installing the update on my '12 Durango Citadel. My DVD drive doesn't reliably read CDs or DVDs, so its failed every time to update from optical media (don't get me started on that - dealer said they had fixed it before I bought it). So I figured no biggy, I'll install it from a thumb drive. I couldn't get the thumb drive to show up until I copied an MP3 file to it, but then all it did was play that ONE MP3 on the drive and not read an update the 730s firmware. This shouldn't be this damn hard to update ! Should I now try to copy the file from the thumb drive to the units HDD and run it from there ? I do have a full bumper to bumper warranty on it, but consider it such a trivial thing to run to a dealer and lose it for a day.
 

·
Registered
Joined
·
158 Posts
Dunno, I have the 430RBZ so I had 2 updates when I got my unit used. (also as a note mine came out of a Jeep only difference is my back light on the buttons is green instead of blue I believe.) Anyway, I hooked up the unit for the first time (It booted with the Jeep logo the first time) plugged in my first USB drive with the RHB-RBZ.33.01.23 update. It detected it right away I installed it which took a bit. Once it rebooted it has started with the Dodge logo's from then on. Then I installed the RHB-RBZ.50.01.01 update right after with no issues. Both just put in a single folder on the root of the thumb drives. Both had no other files on them.
 
1 - 20 of 40 Posts
Top