Dodge Durango Forum banner

1 - 3 of 3 Posts

Registered
Joined
29 Posts
Discussion Starter · #1 ·
Hi 馃憢
Need some help here.
I own Durango 2014, living in middle east hot weather. It was cruising fine till few weeks back it start to show less cooling. As it was out of guarantee already, dealership advised to change Evap. Done changed it . Here the problem started. Looks like they didn't bleed it well, so boiling water sound start to come and my oil temp start to rise up to 230 F. However Trans temp was perfectly normal as usual. Cooling is fine but heating engine oil. Here I want to mention that guage didn't cross middle white mark but almost reaching close to it. Went back to same dealer}done bleeding.. still boiling.. they said thermostat needs to change,done as well.. then they said heater core is blocked. Wow..
They they said Radiator is blocked and it needs to be fixed or replaced.done also as per their recommendation, still heating up oil temp and boiling sound.. left over D to them for 2 days, replaced heater hose under the dash n rechecked Evap .. got it back 5 days back.
Now the issue is when Ac or heater is on temp of engine oil is perfectly fine as it was before upto 97C/206 F to 103C/217-220F.. trans temp is still fine but guage is fluctuating from normal position to almost touching mid white mark but doesn't crosses it.. but when I turn off Ac or heater.. and I'm driving at low speed I'm traffic at speed of 10 - 40 kmh it will start to spike up temp again to 110C/230F..and guage mark is about to touch the white line..
I again called dealer today but they are saying upto this temp is normal and if it crosses mid white mark irrespective of oil temp reaching 230F, no need to worry.. but I am worried, it never happens since last 6 years that temp rise to this level, and already spent a lot of money since I love my D drive.. please need some help and guidance how to figure out what's the problem going on.. desperately need help as don't wanna spend more bucks as so far I changed so many stuff and still it's not fixed..
Durango Limited edition
5.7L, HEMI
 

Registered
2016 Durango R/T Arizona
Joined
507 Posts
I have no experience with this problem but it sounds like a cooling fan issue since you didn't say anything about that. The AC controls the fans differently and must be doing it properly, but when you turn the AC off it sounds like your cooling fans aren't on soon enough, runnning long enough or maybe not running at full speed.
 
  • Like
Reactions: rhobll

Registered
Joined
29 Posts
Discussion Starter · #3 ·
I have no experience with this problem but it sounds like a cooling fan issue since you didn't say anything about that. The AC controls the fans differently and must be doing it properly, but when you turn the AC off it sounds like your cooling fans aren't on soon enough, runnning long enough or maybe not running at full speed.
I checked with the dealer about fan issue, they said relays are checked and all fine, also low and high fan, as per them, are working fine.. But even it's getting hot. One more thing that I noticed just today that I hear some boiling water sound when temp peaked in heavy traffic and snail movement.. could this be the cause? I bleed/burp it so many times at dealership and myself..
Booked an appointment with another dealer and will visit them and update here..anyone got any idea that I may try before going there..
 
1 - 3 of 3 Posts
Top