Dodge Durango Forum banner
1 - 3 of 3 Posts

·
Registered
2012 Durango R/T
Joined
·
19 Posts
Discussion Starter · #1 ·
Background:

I have installed the Mopar hitch on my 2012 R/T, the Build sheet shows the full size spare, Leveling suspension, heavy duty cooling, and the tow/haul button!

I mostly tackled this because I saw that it had the connector for the break controller above the OBDII port, and low and behold when I dropped the spare the other end of the harness was there (SWEET!)

I had read on the forum that in many cases the dealer had to activate, however in some cases they did not (so I obviously had my fingers crossed that I would be safe without)

After I finally got my last part (brake controller) I went out to test (with a digital multi-meter) all of the pin outs of the 4 and 7 pin connector.

I got the same results for both, so I'll only detail the 7 pin here:

Constant power: Good
Reverse: Good
Running lights: Good
Electric brake voltage signal: Good
Left Turn signal: Nothing
Right Turn signal: Nothing
Brake lights: Nothing

Mostly, when I read the forum the terms "does not work" is often used, which does not really go into detail about what specifically is the problem. I have seen a couple that did "zero into" the brake and tail lights, but no details on the other parts (which in my case do work).

Note that I looked at my fuse box (under the hood) and appeared to have all the fuses and relays that were labeled something to do with towing, I even swapped them with similarly rated components (one relay was for the HAVC, and that still worked after the switch, so I believe all the components are good). I can add a photo of the fuse box and schematic if that helps (and once I figure out how to add photos).

So ultimately I am asking is: are there any areas I missed (alternate fuse box? etc.) and what are the specific aspects of the wiring harness that are activated at the dealer?

Note: I called 4 dealers to get an estimate, and got hugely different "quotes" I really didn't want to do it after the first call I made, but am feeling better after calling around a bit (especially after seeing what people were charged here on the forum)

Dealer #1: $165
Dealer #2: $65
Dealer #3: $75
Dealer #4: $110

Thanks in advance.
 

·
Registered
Joined
·
57 Posts
I've got a 2011, and my understanding (so take this with a grain of salt) is that if your D has the 'tow package' the 7-pin works. Mine did and I have the tow package. Those without the tow package need to be flashed by a dealer. Since you mention installing a hitch, I assume you don't have the tow package and therefore would need to have a dealer flash the computer.
 

·
Registered
2012 Durango R/T
Joined
·
19 Posts
Discussion Starter · #3 ·
Thanks, I came (begrudgingly) up to the same conclusion...

Truth be told, I literally just came back from the dealer, after they flashed it (went to dealer #2 above incase there was any question about that :p)

I brought a DMM with me to check the work after it was done (saw to many posts about it "not working" the first time), and they did in fact tell me when I asked if they checked it, that the first time they did it "only activated the parking lights" (which is funny because those always worked), but they did it a second time before I returned (had an early lunch and they were able to do it right away with the appointment I had set), and I was able to confirm that the 4 way pin had power now (I forgot which was ground on the 7 way, but I trust that works as well... ) just have to connect it to the camper when I get home.

Since there were only labor charges, and no parts added, I think it is safe to say that it is what needed to be done.

Anyone reading this now, just keep in mind to call a couple dealers before going with one, with $100 price difference for the same service, you can't afford not to!
 
1 - 3 of 3 Posts
Top