Dodge Durango Forum banner

21 - 32 of 32 Posts

·
Registered
Joined
·
101 Posts
**Following.... I also have the "thud sound" when in reverse. My nephew whos a mechanic was like it may be drivetrain slack with or something to do with the limited slip dif.
It's not the limited slip differential because Durangos don't have one. They use the brakes to limit slip.
 

·
Registered
Joined
·
101 Posts
The issue doesn’t seem to be limited to any one trim level, so the differential probably isn’t the culprit.
 

·
Registered
Joined
·
452 Posts
The issue doesn’t seem to be limited to any one trim level, so the differential probably isn’t the culprit.
It’s something in the driveline. Kinda like the Chevy clunk when letting off the gas and hitting it again. The slip yoke has play and makes a clunk when it engages again. .



2018 Diamond Black Durango SRT
 

·
Registered
Joined
·
17 Posts
mine does it. I assumed it was the brakes letting go. I believe these are like most of the other FCA products where it has some form of line brake that holds the vehicle on hills. it feels like a brake caliper simply under pressure letting go to me.
 

·
Registered
Joined
·
3 Posts
107922


not super helpful but noticed this changing the oil. I have the same sound and have not added the missing bolt yet. Could be the source. threads don’t line up on frame lift so I’ll try soon and repost. Curious if anyone else has an SRT Had this part put together by the same stoner guy.
 

·
Registered
Joined
·
3 Posts
Does it happen as soon as you shift into reverse? Does it clunk when you brake in reverse? Or does it do both?
To me it sounded like a Cow Bell, turned out to be the sensor for the emergency brake. And the technician reset the sensor, the service guy said he was told that the sensor light was blinking and blaring. Go figure!! I can back up with no sound now.
 

·
Registered
Joined
·
3 Posts
To me it sounded like a Cow Bell, turned out to be the sensor for the emergency brake. And the technician reset the sensor, the service guy said he was told that the sensor light was blinking and blaring. Go figure!! I can back up with no sound now.
I should point out the sound came from the front. After resetting the sensor, they couldn't replicate the sound and even made fun of me, when I said the sound reminded me of a Cow bell. Asked I ran over one!!
 
21 - 32 of 32 Posts
Top