Dodge Durango Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hi guys!

I recently replaced the IAC on my 99 Durango SLT 4x4. For about three days, she ran like a champ! Now the IAC valve seems to be stuck open and it high idles all the time. When you pull air filter intake cover off you can hear the air sucking though the IAC port and when you place your hand over that area of the throttle body and let it create a vacuum on your hand it starts to idle correctly. Do you guys think this is a bad IAC that I happened to by or is something else causing this? I replaced the IAC because it was having erratic idle. Going from high idle to not idling at all. Now it just high idles. Any help would greatly be appreciated. Thanks.
 

·
Super Moderator
Joined
·
12,708 Posts
Huh...

I guess I'd reseat the connections at the IAC and the PCM to start.

No OBD codes?

...tom
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
I have't been able to check the OBD yet. I will try resetting the PCM and the reseating the IAC connector in the meantime though.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
I reset the PCM and Check Engine light went off. As soon as I hit the gas it kicked back on and is still high idling, although not quite as high. About 1000 RPM.
 

·
Super Moderator
Joined
·
12,708 Posts
you may be able to get the codes with the "key dance"..

turn the ignition on-off-on-off-on (never to 'start'), then watch the odometer.

IIRC if you have a blue-green odometer (not an LCD odometer) it should work.

...tom
 
1 - 5 of 5 Posts
Top