Dodge Durango Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I have a 2015 Durango. I’ve been dealing with a AC/heat for months. Since I purchased the vehicle. Dealership cannot figure out what’s going on. I’ve taken it in 4-6 times.
The issue I have is sometimes when I turn the vehicle on no air will blow out of the front air vents or middle console. Doesnt matter if it’s on heat or AC. Air will blow out of the back but it’s warm air. Then Randomly sometimes when I hit a bump in the road It will turn on and work like normal. No problem. I’ve already checked the freon. It just randomly doesnt work. Only when the vehicle gets turned on. It’s never been working fine and then not work while driving. I don’t get what’s going on. Anyone else have this issue please help?
I live in Texas and it’a hot. With little kids in the car. This is not fun.
 

·
Registered
Joined
·
52 Posts
for starters, if you've gone to the same dealer 4-6 times you need to go to a different dealer, or any reputable shop for that matter. at this point, with the age of the vehicle, i would say you can go to any high rated mom&pop shop and someone will have a better technical experience with many different AC's and can find the problem

secondly, your description of the problem is a little all over the place and not very clear

having said that, to me it sounds like an electrical issue, but that's only based on you saying when you hit a bump it starts working again. kind of like a crappy flashlight that you have to hit to make it shine. this could be in the form of a male/female connector or something soldered or a ground....etc.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
I’m taking it back to the dealer because they are the ones covering the cost to fix it.

for starters, if you've gone to the same dealer 4-6 times you need to go to a different dealer, or any reputable shop for that matter. at this point, with the age of the vehicle, i would say you can go to any high rated mom&pop shop and someone will have a better technical experience with many different AC's and can find the problem

secondly, your description of the problem is a little all over the place and not very clear

having said that, to me it sounds like an electrical issue, but that's only based on you saying when you hit a bump it starts working again. kind of like a crappy flashlight that you have to hit to make it shine. this could be in the form of a male/female connector or something soldered or a ground....etc.
 

·
Registered
Joined
·
52 Posts
I’m taking it back to the dealer because they are the ones covering the cost to fix it.
Well if that's the case then yea I'd keep going to them, too.

But if a different shop has another opinion that might help as well. Sounds like at some point most of your interior is going to be removed to try to find the problem, and everytime a dash is removed and reinstalled there's about a half a dozen leftover screws and clips lol
 

·
Premium Member
Joined
·
4,491 Posts
Married:
Welcome to DDN. It's good to hear that your selling dealer is working with you on taking care of this issue. As mentioned, your problem sounds like a wiring or loose connector type of malady. Are you having any other kinds of issues with the display screen that controls the radio/HVAC etc? These systems are great when they work, but a nightmare when they are problematic. '14/'15/'16 model years it seems, were more problematic than others. How many miles on your '15, and what model/engine?

Don
 

·
Registered
Joined
·
287 Posts
I have a 2015 Durango. I’ve been dealing with a AC/heat for months. Since I purchased the vehicle. Dealership cannot figure out what’s going on. I’ve taken it in 4-6 times.
The issue I have is sometimes when I turn the vehicle on no air will blow out of the front air vents or middle console. Doesnt matter if it’s on heat or AC. Air will blow out of the back but it’s warm air. Then Randomly sometimes when I hit a bump in the road It will turn on and work like normal. No problem. I’ve already checked the freon. It just randomly doesnt work. Only when the vehicle gets turned on. It’s never been working fine and then not work while driving. I don’t get what’s going on. Anyone else have this issue please help?
I live in Texas and it’a hot. With little kids in the car. This is not fun.
Hi married43007,
We sincerely regret hearing of the trouble. Please know that our team would be more than happy to provide you with an additional layer of assistance if you do end up connecting with your dealer again. Feel free to follow up with us via private message if this would be of interest.

Rob
Dodge Cares
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #8 ·
I am going back to dealers again tomorrow. AC didn’t work all day today.

Hi married43007,
We sincerely regret hearing of the trouble. Please know that our team would be more than happy to provide you with an additional layer of assistance if you do end up connecting with your dealer again. Feel free to follow up with us via private message if this would be of interest.

Rob
Dodge Cares
 

·
Registered
Joined
·
287 Posts
I am going back to dealers again tomorrow. AC didn’t work all day today.
Hi married43007,
Please feel free to keep us updated regarding your situation. If we can be of any additional support while your vehicle is in service, we're just a PM away.

Rob
Dodge Cares
 

·
Registered
1999 Durango SLT 4x4
Joined
·
38 Posts
Ask your dealer if they've scanned the system for codes and, if so, what did they find? Write stuff down if they won't

These things typically do a self check or "sweep" of controlled features at start-up and would send a code if anything isn't responding correctly.

While this could be an electrical issue, as.others have said, it might also be a mechanical problem with an air flow diverter or temperature blend door.

A code or codes would make me think electrical while no codes might indicate a mechanical problem.

You need to start being the "squeaky wheel" and questioning everything that's being done.
Be polite but firm about how long this has taken.

Good luck.
 
1 - 10 of 10 Posts
Top