Dodge Durango Forum banner
101 - 120 of 131 Posts

·
Registered
Joined
·
161 Posts
so do any other HC owners have sketchy looking wiring like mine?
Yes, I am pretty sure they are all that way if you are asking about the tape around the end of the harness sheathing at the connectors. Here are a few pictures of mine. My routing is a bit different as I have the JLT intake installed so I had to relocate the PCV valve. My Durango Hellcat was built March 18. I remember tweaking a few of the harness routings after I took delivery and got it home as some of them didn't seem to be routed from point A to B as smoothly as they could have been.

117033


117034
 

·
Registered
Joined
·
153 Posts
I haven't looked or jacked it up. But lately after sitting a day or two (or a week). I get a grind (wouldn't even call it that, hum? vibration?) which I can also feel via the pedal, on the front right. Just happens once or twice (as in wheel rotation) and never again until it sits. My first thought is brake pads/rotor. No clicking/binding or any other noises when turning.
 

·
Registered
Joined
·
1,225 Posts
I haven't looked or jacked it up. But lately after sitting a day or two (or a week). I get a grind (wouldn't even call it that, hum? vibration?) which I can also feel via the pedal, on the front right. Just happens once or twice (as in wheel rotation) and never again until it sits. My first thought is brake pads/rotor. No clicking/binding or any other noises when turning.
Sounds like the brakes. Mine sat for 10 days and I drove it without any noises. But, my wife's Kia gets that noise from the front if it sits for more than a day. Dealer found the pads oxidated and sanded them down at 3000 miles but it has returned. According to the dealer they will be replacing the pads. Hopefully that eliminates the issue.
 

·
Registered
Joined
·
301 Posts
Discussion Starter · #108 ·
I haven't looked or jacked it up. But lately after sitting a day or two (or a week). I get a grind (wouldn't even call it that, hum? vibration?) which I can also feel via the pedal, on the front right. Just happens once or twice (as in wheel rotation) and never again until it sits. My first thought is brake pads/rotor. No clicking/binding or any other noises when turning.
Sounds like rust buildup on the rotors, especially if it goes away after a few braking cycles. If you do hear any clicking, that’s typical with the two-piece rotors on these trucks, but is usually more consistent.
 

·
Registered
Joined
·
2 Posts
Vehicles in the passing lane are unable to impede my travel. It seems dodge did not install that wind up time it takes to get around someone who won’t get over.

Passing power is only duplicated by vehicles which cost in access of 200k.

I’m not experiencing any back pain on trips in excess of 500 miles.

Slight crumpling sound from gas tank at WOT. Almost like the fuel is being sucked out of the tank at a rapid rate.

Seems I’m unable to pass a gas station. In all honesty I didn’t expect to anyways.

I now feel as if I no longer need to go to amusement parks for a thrill ride.

I was able to Immediately locate a pin I dropped inside the cabin.

I have had that grinding noise a couple of times but I’ve ignored it. I feel it will eventually go away on its own or I will have ignored it to the point I won’t hear it when/if it happens again.

My wife who is a gear head car nut loves it. She’s a bit of a snob and usually drives AMG or M/// cars. She was a bit apprehensive about dropping 100k on a dodge. Now she won’t get out of the drivers seat.

I’m gonna rack insane miles on this thing and have a blast doing it!
 

·
Registered
Joined
·
29 Posts
Vehicles in the passing lane are unable to impede my travel. It seems dodge did not install that wind up time it takes to get around someone who won’t get over.

Passing power is only duplicated by vehicles which cost in access of 200k.

I’m not experiencing any back pain on trips in excess of 500 miles.

Slight crumpling sound from gas tank at WOT. Almost like the fuel is being sucked out of the tank at a rapid rate.

Seems I’m unable to pass a gas station. In all honesty I didn’t expect to anyways.

I now feel as if I no longer need to go to amusement parks for a thrill ride.

I was able to Immediately locate a pin I dropped inside the cabin.

I have had that grinding noise a couple of times but I’ve ignored it. I feel it will eventually go away on its own or I will have ignored it to the point I won’t hear it when/if it happens again.

My wife who is a gear head car nut loves it. She’s a bit of a snob and usually drives AMG or M/// cars. She was a bit apprehensive about dropping 100k on a dodge. Now she won’t get out of the drivers seat.

I’m gonna rack insane miles on this thing and have a blast doing it!
"Slight crumpling sound from gas tank" Ha ha!! Great line!
 

·
Registered
Joined
·
153 Posts
keep up on checking the oil levels.. 4k mi was down a good quart. (maybe this is motivation to install that catch can i've had sitting around)
 

·
Registered
Joined
·
1,359 Posts
Catch cans do work as advertised but I'm in the camp of let the oem system of re circulation do its thing.People seem to have a vax no vax kinda feeling about them... :eek:
 

·
Registered
Joined
·
27 Posts
Has anyone run into an issue with engaging cruise control on their DDHC? Mine says it's in "Plant Mode" and Google doesn't seem to be my friend on this one. Just took delivery a few days ago and the only major issue thus far.
 

·
Registered
Joined
·
301 Posts
Discussion Starter · #114 ·
Has anyone run into an issue with engaging cruise control on their DDHC? Mine says it's in "Plant Mode" and Google doesn't seem to be my friend on this one. Just took delivery a few days ago and the only major issue thus far.
Sounds like your dealership didn't take it out of shipping mode when they did their PDI.
 
  • Like
Reactions: Buck99rog

·
Registered
Joined
·
27 Posts
Sounds like your dealership didn't take it out of shipping mode when they did their PDI.
Swung by the dealer and they were able to resolve the issue. Apparently they verified it was out of "shipping mode", but the issue persisted so they had to re-calibrate the adaptive cruise module, which solved it. They say it's the first time they've seen that. Pretty quick fix.
 

·
Registered
Joined
·
301 Posts
Discussion Starter · #116 ·
Swung by the dealer and they were able to resolve the issue. Apparently they verified it was out of "shipping mode", but the issue persisted so they had to re-calibrate the adaptive cruise module, which solved it. They say it's the first time they've seen that. Pretty quick fix.
Weird, I've never heard of that one. Regardless I'm glad to see you got it resolved.
 

·
Registered
Joined
·
27 Posts
I'd get the full PDI list and check to see if everything else that they swear they already did needs to be re-calibrated.
FWIW, I did a cursory search of the PDI checklist and if the ones I found online are accurate, the only thing that didn't work after delivery that was on the sheet was the cruise control. Hopefully I can stay out of the shop until the post-break-in oil change. :)
 

·
Registered
Joined
·
27 Posts
Any idea what this bolt might go to? It was rolling around under the front passenger seat and isn't obvious where it might have come from.

Light Household hardware Coil Finger Coil spring
 

·
Registered
Joined
·
357 Posts
Any idea what this bolt might go to? It was rolling around under the front passenger seat and isn't obvious where it might have come from.
Hi kvanals,
If you are not able to remedy this concern with the advice provided here; we kindly recommend connecting with your local Dodge dealer. If you are in need of any assistance with that process, our team is available via private message.

Rob
Dodge Cares
 
101 - 120 of 131 Posts
Top