Dodge Durango Forum banner
61 - 80 of 80 Posts

·
Registered
Joined
·
1,196 Posts
after only about 180 miles the vehicle lost site of the keyfob which was in it the whole time with me, No issues other than the dash warning that the fob had left the building.....:sneaky:
 

·
Registered
Joined
·
231 Posts
after only about 180 miles the vehicle lost site of the keyfob which was in it the whole time with me, No issues other than the dash warning that the fob had left the building.....:sneaky:
Hi frictioncircle,
Feel free to let us know via private message if you plan to work with your dealer to resolve this. We're happy to provide you with additional assistance during that process.

Rob
Dodge Cares
 
  • Like
Reactions: Ollie Crow

·
Registered
Joined
·
231 Posts
  • Like
Reactions: Ollie Crow

·
Registered
Joined
·
9 Posts
I am in the “electronic bugs” category.
Sometimes I can switch driving modes- other times it is not available at all- nor is the Performance Pages or Race options.
Dealership appointment one week from today.
We had this issue as well and the dealer fixed it. I'm still not clear on exactly what the issue was. We had an o2 sensor issue as well at the time.
 

·
Registered
Joined
·
92 Posts
I have a clicking noise like a rock in the tire coming from the passenger side. It’s either a heat shield or a brake issue. Dealer is looking at it soon. Other than that my Uconnect has been solid along with everything else
 

·
Registered
Joined
·
1,196 Posts
You have to laugh..my detailer just showed me that the front fender HC logos are an inch off one higher than the other..luckily they are just taped on... 🤨
 

·
Registered
Joined
·
128 Posts
You have to laugh..my detailer just showed me that the front fender HC logos are an inch off one higher than the other..luckily they are just taped on... 🤨
The assembly jig has to be off at the factory as all of them are that way. I had them balanced after my PPF was applied.
 

·
Registered
Joined
·
4 Posts
I got a good one, drive train module failed part is 7-8 days out 😅 I've got 4 days till I get it back 😭
 

·
Registered
Joined
·
35 Posts
Mine was leaking in the trunk area. Apparently the vehicle wasn’t sealed from factory. Took about 4 days to get it fixed. The first dealer looked at it under the rear headliner and said they couldn’t touch it and it had to go to body shop. Luckily body shop fixed it and. Ow I have to get the dealer to fix the clips they broke when removing the headliner, I mean why would they fix it unless something is said, customer service these days is absolutely pathetic. The last 3-4 Dodge vehicles I’ve purchased have had stupid issues with them and having the dealer look at them is the most difficult part it seems.
 

·
Registered
2020 DDSRT Octane Red, 2020 Ram 1500 Crew Cab, 2021 HD FLHXS
Joined
·
84 Posts
Could mean leaking from the sunroof, antenna, or sealant around windshield.
 

·
Registered
Joined
·
128 Posts
Wasn’t the sunroof, was the rear window and a hole under the trim on roof
There has been at least one other like that which had water on the inside of the rear window during rain.
 

·
Registered
Joined
·
8 Posts
Hello! I just picked up my DDHC on Friday and drove it 1400 miles home. I am having a strange grinding sound coming from the front passenger's wheel well. I didn't discover it until about 500 miles, as I was abiding by engine break-in.

It happens only under very hard acceleration in 1-2 gears and the very bottom of 3rd - I would say 80% throttle and greater. It sounds like a rotational grind, like sheet metal grinding a tire or wheel. I checked everything I could on the ground but will get it up on the lift later this week. Does not happen on heavy highway pulls. It is a pretty unsettling sound, and very apparent with the windows closed.

Has anyone else experienced anything like this? I am seeing DDSRT0311 has a bad cat, maybe an exhaust rub, but mine definitely seems driveline/brake related. I will report back if i find anything glaring.
 

·
Registered
Joined
·
7 Posts
After getting full PPF and 15% window tint and putting on a few hundred miles locally, I drove my Hellcat from South Florida to Massachusetts and then back...oil change at 1,500 miles, now have close to 4,000 miles so far on the car...no significant issues (knock on wood), and that long road trip included an 800-mile day in 95-100+ temperatures with only 2 quick gas stops, a 50-mile stretch through a tropical storm, and in general my typical "enthusiastic" driving...

I have nothing but great things to say about the car at this point. The only minor issues I have experienced are:

1) the horn occasionally makes a strange sound in the cabin (not to be crude, but it sounds like a farting noise, which I oddly also experienced in a brand new Charger rental last year)
2) extreme amounts of of break dust for me to clean:p

I will be taking the car across the country from South Florida to Los Angeles (and back) in a few months after another oil change/tire rotation (6k service?), so it will be interesting to see how the car performs then.
 

·
Registered
Joined
·
1,148 Posts
I have nothing but great things to say about the car at this point. The only minor issues I have experienced are:

1) the horn occasionally makes a strange sound in the cabin (not to be crude, but it sounds like a farting noise, which I oddly also experienced in a brand new Charger rental last year)
2) extreme amounts of of break dust for me to clean:p

I will be taking the car across the country from South Florida to Los Angeles (and back) in a few months after another oil change/tire rotation (6k service?), so it will be interesting to see how the car performs then.
Was the rental also used on a road trip? If so, that noise 1) is definitely caused by road trip food...:cool:
2) is a common theme among SRT owners. Keep washing the wheels or switch out the brake pads.
 
61 - 80 of 80 Posts
Top