Dodge Durango Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
134 Posts
Discussion Starter #1
Hi so my durango has no power .9.5 mpg hwy . it starts up no prob idles sewing machine sweet .. has a vac reading of 19.5 a snappy throttle response but go drive and its no power goin up hills struggles downshifts but still lacks power what i noticed is when floored the rpms drop but when i lift off throttle for brief moment it will accelerate but then drops ... the durango is a awd . Mtr is rebuilt 5.9 rebuilt trans new distributer. Fuel sync at 0 . new mopar crank,map ,air temp .sensor new ntk front oxygen sensor, denso rear, autozone duralast tps.the intake manifold has had the plenum gasket repair and kegger mod . The fuel pump is new bosh rebuilt pcm . Exhaust is new inc cat . New ignition coil and more ....also no codes and shows no missfires..what am i missing
 

·
Registered
Joined
·
45 Posts
Need to do some diagnostic troubleshooting. Start with compression test and leak down test. Check all 8 cylinders for firing. With a temperature gun, check each cylinder for temperature above 350 degrees (indicating its firing).

Can you disconnect muffler before catalytic converters and see if any back pressure exists.
What do the plugs look like?

Did this problem exist before the rebuild?

Why were all these parts replaced? Trying to resolve this issue?

Sent from my SM-N960U using Tapatalk
 

·
Registered
Joined
·
134 Posts
Discussion Starter #3
Everything was replaced as a full rebuild she had 245000 miles plugs were clean as she's only got 5000 on rebuild .. she was getting 13.5 with multiple cracks in the prior heads.. also new cam and lifters used ...
 

·
Premium Member
Joined
·
2,965 Posts
Can you hang a fuel gauge on the rail, and verify that pressure is where it should be. With with a VAC reading of 19.5, I can't imagine you have a restriction unless it drops and stays low as rpms increase. I suspect that Bosch FP might not be up to snuff. What happens if you try some old school powerbraking? Does it bog, or seem to want to get up and go?
The battery is new, or fairly so, correct?

Don
 

·
Registered
Joined
·
134 Posts
Discussion Starter #5
Hi fuel press is now 48 solid and holds for hrs.. issues were doing this before the pump replacement which was done as the regulator was bad .. the ride wants to go with a power brake but not peel out its awd .. and weezes out at high speeds but not missfiring.. could plugged injectors do this ? as i have some 4 hole bosch injectors that r for the durango that i could swap in .. and wouldnt a faulty or weak new ign coil cause a missfire situation ??? Its like having a 3 cylinder geo stuffed in the ride minus the good mpg ...
 

·
Premium Member
Joined
·
2,965 Posts
Good on the FP pressure. Is the 48 PSI at idle, or are you able to monitor it as you are cruising, and the problem appears? How about plug wires? They are new correct? An engine with the old schol HV wires will often idle fine, and lope around town. When you get into the upper rpm ranges though, the failing part(s) break down. Recheck dist cap, rotor, and make sure wires are all still fully seated on both ends.

Don
 

·
Registered
Joined
·
134 Posts
Discussion Starter #7
Ok so will check dist cap and ohm wires out even though new crap happens .. i just did a block/head test and good stayed the orig blue till i went too tailpipe and did 1 wiff and changed to yellow pee so gasket is good did it twice.. but after shutdown i heard this clicking noise i always thought it was a metal heat tic well anyway got a pipe and traced it to the back pass side fuel injector area it ticks for about 1 to 2 mins .. is this a check valve in injector goin bad??? Or what the #$%&÷ is it
..
 
1 - 7 of 7 Posts
Top