Dodge Durango Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
11 Posts
I typically don't use the nav feature because the phone is way better. However just out of curiosity I turned it on today and saw this. View attachment 111538

Apparently my car is amphibious LOL.

Also the built-in phone broke today, not sure if related.

My D was doing this a while back. It went away after a day or so. I’m thinking whatever they use like gps sat was just a little off that day. I thought I was going to need an update of some sort but it stopped doing it .
 

·
Premium Member
2020 RT Destroyer Grey Blacktop
Joined
·
139 Posts
Hahaha!!!! Right! I use carplay all the time. I don't understand why they put nav in cars that have car play or whatever the Android comparable one. Take that money and put it into better breaks or taking the sticker price down.
 

·
Registered
2014 Jeep Grand Cherokee Overland V6
Joined
·
1,700 Posts
Do you have the latest Uconnect software installed? Not the Map software..that's separate.
 

·
Registered
Joined
·
224 Posts
In one of our previous cars, a Chevy Volt, something similar to this happened and they had to replace the GPS antenna. It was still moving around but wasn't accurate as to where the vehicle actually was.
 

·
Registered
Joined
·
70 Posts
The same thing happened to me a few years ago. It was also telling me to turn left into a cement barrier. The dealer update the the system. And all is good now.
 
  • Like
Reactions: DBSRT

·
Registered
2014 Jeep Grand Cherokee Overland V6
Joined
·
1,700 Posts
My 2014 JGC was all over the place except where I was physically located. I had really old Uconnect system software and had to do 2 different updates to the latest which for me is 18.45.01.

There was some change to the GPS satelitte system that hosed up all the vehicle manufacturers NAV systems. They all had to release updates to take care of this including Fiat/Chrysler.
 
  • Like
Reactions: DBSRT

·
Registered
Joined
·
33 Posts
Update the Uconnect. You can try to do a radio reset or even d&r the battery. If it doesn't fix it, you will need a new HU. Its more common issue than people tend to believe.

The one on my 18 Hellcat went out recently. It thinks I am in the middle of the ocean. Has all the updates but out of warranty due to all my mods (car only has 10k miles).
 

·
Premium Member
2020 RT Destroyer Grey Blacktop
Joined
·
139 Posts
Update the Uconnect. You can try to do a radio reset or even d&r the battery. If it doesn't fix it, you will need a new HU. Its more common issue than people tend to believe.

The one on my 18 Hellcat went out recently. It thinks I am in the middle of the ocean. Has all the updates but out of warranty due to all my mods (car only has 10k miles).
Is your head unit modded? If not why wouldn’t that be covered?
 

·
Registered
Joined
·
33 Posts
Is your head unit modded? If not why wouldn’t that be covered?
No but the car is modified. That is enough reason for them to say no.

They also reprogram the HU after replacing, which I cannot have happen. It will erase my tune and I will have to have the ECU sent out to have unlocked again. My car will not run properly on the stock tune.

The other issue is when they do connect to my car, it has a hard fault code store that the ECU was disconnected. I also have 2 bypass cables installed which Im sure they would question.
 

·
Registered
Joined
·
4,992 Posts
So if you're using Waze or Google Maps through CarPlay on it...does it still show you in the ocean?
Or are we talking about the factory nav software?
 

·
Registered
Joined
·
22 Posts
Discussion Starter #14
I downloaded the Uconnect update and tried installing it, what ended up happening was a terrifying couple of days of the infamous Sierra Wireless BOLO failure/67%. Do yourself a favor and first google Uconnect update failure and don't update it yourself. The install was stuck in a loop that will drain your battery (won't turn off even when you leave the car), and I read online that sometimes you'll just have to get a new radio which was 2500 plus labor.

I took the car to a nearby dealership and they were able to do some kind of hard reset and fix it (not sure what they did) but it was a pretty frustrating couple of days.

Everything works now and the GPS is fine and no more 911 phone problem which is directly tied to the GPS problem.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #16
Ok the 911 failure is back and my GPS says I'm swimming again. As much as I love this car's mechanical bits the electronics are really much to be desired. My radio is already updated so I'm not sure what else is wrong. The AM and FM reception is non-existent which is odd, the sharkfin antenna is still there. Any thoughts?
 

·
Registered
Joined
·
9 Posts
Ok the 911 failure is back and my GPS says I'm swimming again. As much as I love this car's mechanical bits the electronics are really much to be desired. My radio is already updated so I'm not sure what else is wrong. The AM and FM reception is non-existent which is odd, the sharkfin antenna is still there. Any thoughts?
Same thing on my 2018 GT. I've called UConnect and they sent me to the dealer. Today, the dealer called me and said that they have to change the unit and will be 3-4 days delay. Is not that I'm using the navigation but I don't want it to be bricked after the warranty. I'm still covered.

PS I live in Montreal, Canada area and the NAV is seeing me in Vermont or upper NY.
 
1 - 17 of 17 Posts
Top