Dodge Durango Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hello all,
I'm hoping someone out there has an answer to my problem. In short, ABS not working. All lights are normal (they go through there start up process then go out as I'd expect).

My problem, truck has "rear wheel ABS" but not working.
Truck is 2000 Durango 4x4 4.7.
I did change the ECU and don't remember if the ABS worked with the old ECU. Everything else is fine
Question; does the ECU somehow control the ABS system ? If so, do I have to go to the dealer to have the ECU flashed ?
Is there a code reader that will flash the ECU ???

Thanks
 

·
Super Moderator
Joined
·
13,001 Posts
ECU ("PCM") doesn't really control the ABS. PCM does have to be programmed for the correct ABS configuration (RWAL vs 4WAL) if it wasn't already correct.. but I think you'd have an ABS light if that wasn't right.

How do you know the ABS is not working?
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Thanks for the reply.
I'm new to this 2000 D (2nd winter) bought it on its way to the junk yard. So far all has been fixed or replaced. Living in New England with the snow, you learn quickly when the rear wants to be in the front there's an issue.
Along the way I picked up an ECU from eBay for 2 reasons CEL was on (don't remember code) 2 Aux Elec cooling fan wouldn't trigger by ECU check.

Some time after that I realized no RWR ABS.
I believe the ABS system is good, only because it seem to pass it's "startup self check"
 

·
Super Moderator
Joined
·
13,001 Posts
Gen-I RWAL (rear ABS) is not all that impressive.. it is basically the system that the Dakota uses to meet the federal pickup-truck RWABS requirements.. it is a single-channel system (the two rear wheels get ABSed together)..

Pragmatic solution might be to have tires with better grip on the rear in winter :(
 
1 - 4 of 4 Posts
Top