Dodge Durango Forum banner
1501 - 1520 of 1901 Posts

·
Registered
2021 Durango SRT, 2017 Chrysler 300S 5.7
Joined
·
366 Posts
I got the .99 update and it is a FAIL


1. Touch beeps do not work
2. Weather map keeps bringing up Nav map which is stupid
3. HVAC controls no longer have the person wearing a helmut no matter which theme (there are only 2) I choose.
4. The loading screen (multi line circles) pops up randomly
5. 4G service is not working
6. middle position seat heating still does not work.
7. I factory reset system and same thing.


There may be more broken items but I could not sit in the Durango any longer (knee was hurting)
I will give the unti a work out this weekend.
I checked mine last night on the way home from work, and touch beeps do work on my radio also....
 

·
Premium Member
Joined
·
2,193 Posts
I checked mine last night on the way home from work, and touch beeps do work on my radio also....

I will get to the DDRT as soon as I can to retest. Hope after 1 day it has time to do what it needs to do to have things working again.
 

·
Registered
2021 Durango SRT, 2017 Chrysler 300S 5.7
Joined
·
366 Posts
I will get to the DDRT as soon as I can to retest. Hope after 1 day it has time to do what it needs to do to have things working again.
I'm wondering if because I have the rear seat DVD's it may make a difference.....shouldn't , but you never know..
 

·
Registered
Joined
·
49 Posts
I got an issue once only when the screen became unresponsive and that was a month ago. But since then it didn't have any issues that I noticed.
 

·
Registered
2021 Dodge Durango SRT Hellcat
Joined
·
29 Posts
Had this problem for 6 months now and no one else seems to have the same issue.

SRT drive modes. I have set a custom drive mode which consists of:
transmission - track
paddle shifters - on
all wheel drive - sport
stability control - sport
suspension - sport
steering - track

Operation on the daily is normal, jump in, start up the car, double tap srt button, start driving in my custom set drive mode.

Now what pisses me off is, every 3 days or so I will start the car and double tap the srt button, only to see my "custom setting" has reverted back to default "street" on everything. Nothing else gets reset on the uconnect, only the srt drive modes..
 

·
Registered
Durango Hellcat
Joined
·
236 Posts
I actually have had that happen a few times. I use track nearly every time so I didn’t pay too much attention before the update but after the 17.89 update it takes a long time for the SRT mode page to load so I just double tap to get it out of auto and into custom. It’s definitely lost my settings because I’ve set them to all track and they have reset at least 2 times now.
 

·
Premium Member
Joined
·
2,193 Posts
Good news. I went to PT today and checked the Uconnect system.
All features are working including helmet heads are showing on theme 1.
I noticed I can now save 36 presets which .89 only had 24 (at least I think it did)
My 4G wifi is working too as well as my weather and weather map.
They still do not have an over speed limit setting, just on or off and it is still 3mph which again is stupid as shit.

I will update the thread when I put more time into using the feature tomorrow during my travels up north.
 
  • Like
Reactions: S8ER01Z

·
Registered
Joined
·
9 Posts
Hey all,

Just picked up my new 2021 durango rt. Have it for 2 days and today I get the following message appear every time I start the car.

I called unconnect and they are unable to help. Told me to go to the dealer. Anyone can suggest how to maybe disable the wifi? Or anything else that can help without going to the dealer.

Thanks!
 

Attachments

·
Registered
Durango Hellcat
Joined
·
236 Posts
Hey all,

Just picked up my new 2021 durango rt. Have it for 2 days and today I get the following message appear every time I start the car.

I called unconnect and they are unable to help. Told me to go to the dealer. Anyone can suggest how to maybe disable the wifi? Or anything else that can help without going to the dealer.

Thanks!
Same nonsense I have, radio replaced. Update to 17.89 but still get the error every time I start the car. I also noticed the Uconnect reports don’t update in my app anymore (2+ months ago was last update)
 

·
Premium Member
Joined
·
2,193 Posts
This is why we all started getting the updates this past week. Whoever is running Uconnect needs to get replaced with someone who cares for the owners and gets things done.
 

Attachments

·
Registered
Joined
·
9 Posts
Same nonsense I have, radio replaced. Update to 17.89 but still get the error every time I start the car. I also noticed the Uconnect reports don’t update in my app anymore (2+ months ago was last update)
I also can't bring up weather. It never loads.

Any other suggestions? At this point I think the dealer won't even help.

This really sucks. I just turned in my 2018 durango and at this point I miss it. Didn't have any issues with it.
 

·
Registered
Joined
·
9 Posts
This is why we all started getting the updates this past week. Whoever is running Uconnect needs to get replaced with someone who cares for the owners and gets things done.
Thanks for this. I really hope that this will fix the issue. Any idea as to when I might see this update pop-up on the system? Also is it possible the since I just got the car that the update was already installed? I see the date is Jan 11, 2022. Thats the same day I got the car.

Thanks again!
 

·
Premium Member
Joined
·
2,193 Posts
Thanks for this. I really hope that this will fix the issue. Any idea as to when I might see this update pop-up on the system? Also is it possible the since I just got the car that the update was already installed? I see the date is Jan 11, 2022. Thats the same day I got the car.

Thanks again!
You would have seen a message on your screen if it updated. You can check your firmware version by going into settings of the Uconnect system.
 

·
Registered
Durango Hellcat
Joined
·
236 Posts
I also can't bring up weather. It never loads.

Any other suggestions? At this point I think the dealer won't even help.

This really sucks. I just turned in my 2018 durango and at this point I miss it. Didn't have any issues with it.
No suggestions on my end, I have to make another appointment with the dealership to see if they can fix the WiFi issue 😞
 

·
Registered
Joined
·
9 Posts
I finally got a chance to use the car today and magically the error is gone. The system works completely fine. I'm not sure what could have caused this issue. It's frustrating, but happy that it's back up and working.

Thank you guys for your suggestions. And good luck to you S8ER01Z hope the dealer fixes it for you.

I'll keep you guys updated if this happens in the future.
 

·
Registered
2021 Billet R/T TNG
Joined
·
818 Posts
Hate to say it, but do you really think anything has changed? It’s the same vehicle, same Uconnect, software and etc. 22s will have similar issues.
 
  • Sad
Reactions: S8ER01Z

·
Premium Member
Joined
·
2,193 Posts
I finally got a chance to use the car today and magically the error is gone. The system works completely fine. I'm not sure what could have caused this issue. It's frustrating, but happy that it's back up and working.

Thank you guys for your suggestions. And good luck to you S8ER01Z hope the dealer fixes it for you.

I'll keep you guys updated if this happens in the future.

I think a lot of these strange wifi conneciton errors as well as Sirius errors are caused by the backend and not the system itself.
Otherwise the errors would not simply clear up on their own if it was the firmware.
 
  • Like
Reactions: S8ER01Z
1501 - 1520 of 1901 Posts
Top