Dodge Durango Forum banner

121 - 140 of 184 Posts

·
Registered
Joined
·
515 Posts




Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
515 Posts
But worse than paying for this after a year is still the fact that I cannot use car play!!!! This is ridiculous


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
515 Posts
My Ford does this for free. No sub needed. I can't believe dodge only gives a year free.
while I agree with you, durango still crushes explorer regardless of this item... it's pretty minor and honestly, it's nothing critical that you're missing if you don't have it? all the info can be seen by just getting in the car i.e. fuel oil mileage and tire pressure... as for remote start, the key fob will always allow remote start so unless you're really far away I don't know why this is needed? I suppose if you live or work on a multi story place in the cold snow it could come in handy but I've owned 4 scat packs and 2 durangos and I've used remote start zero times from the app...
 

·
Registered
Joined
·
515 Posts
what we need more importantly is this darn car play to work already...... that bothers me much more and I hope this software update comes soon.
 

·
Registered
2021 Durango GTplus AWD
Joined
·
79 Posts
what we need more importantly is this darn car play to work already...... that bothers me much more and I hope this software update comes soon.
Sorry carplay is having issues. My wireless android Auto is working flawlessly so far. Im sure thy will get it fixed.
 

·
Registered
Joined
·
126 Posts
Sorry carplay is having issues. My wireless android Auto is working flawlessly so far. Im sure thy will get it fixed.
Hope it lasts. My Android Auto started out good, then started dropping connection with the phone.

Sent from my S20 Ultra using Tapatalk
 

·
Registered
Joined
·
80 Posts
@Heat00 I know this will irk you to no end, but my CarPlay has been pretty good since the dealer did their stuff. I dunno which way to point you but I know mine has had 95% flawless connection issues since the dealer looked at it with @DodgeCares starting the escalation for me. Honestly, the random issue is that it takes 1.5 min to connect instead of immediately. But that is like once every 5 times. Otherwise, I am happy.
 

·
Registered
Joined
·
2 Posts
I haven't had any connection issues, but my performance pages are definitely screwy. G forces especially. I've gotten it to open before, but 9 times out of 10 it crashes.
 

·
Registered
Joined
·
177 Posts
Discussion Starter #130
I haven't had any connection issues, but my performance pages are definitely screwy. G forces especially. I've gotten it to open before, but 9 times out of 10 it crashes.
I did a factory reset and my performance pages work fine now. I was also having the G Force crashing issue.
 

·
Registered
2021 R/T
Joined
·
18 Posts
Is it one year? Thought it was only 6 months. From my window sticker...




Sent from my iPhone using Tapatalk Pro
XM Radio was downgraded to a 6mo trial in 2021. XM Guardian is 1 year.

 

·
Registered
Joined
·
515 Posts
I did a factory reset and my performance pages work fine now. I was also having the G Force crashing issue.
How do you do the factory reset? Pull the fuses like in the charger?

And has this brought back car play connection to anyone that’s tried?


Sent from my iPhone using Tapatalk
 

·
Registered
'21 DD Tow N Go / ‘17 Viper ACR
Joined
·
44 Posts
How do you do the factory reset? Pull the fuses like in the charger?

And has this brought back car play connection to anyone that’s tried?


Sent from my iPhone using Tapatalk
Theres a setting in the uconnect to do a factory reset. I would do it that way. For the carplay issue, go in setting in your iphone, general, and under MyCar you will see Uconnect-cd1b85. Delete it and try to pair again the phone with uconnect.
 

·
Registered
Joined
·
51 Posts
Hi @groucho , thanks for tagging our @DodgeCares team directly!

Sorry to hear about the experience you've had with your Apple CarPlay so far @Heat00 ! If you decide to get this properly diagnosed and addressed by your Dodge dealer and would like additional support, please do not hesitate to send us a private message!

Thanks,

Courtney
Dodge Cares
 

·
Registered
Joined
·
515 Posts
Theres a setting in the uconnect to do a factory reset. I would do it that way. For the carplay issue, go in setting in your iphone, general, and under MyCar you will see Uconnect-cd1b85. Delete it and try to pair again the phone with uconnect.
yes tried that like 10 times lol. bluetooth working fine for phone, but no car play which makes navigation and texts a problem.... built it nav is a pita compared to car play apple maps/google/waze and texts through car play allow it to be used hands free as we don't want to be texting while driving so this is an important feature.
 

·
Registered
Joined
·
515 Posts
Hi @groucho , thanks for tagging our @DodgeCares team directly!

Sorry to hear about the experience you've had with your Apple CarPlay so far @Heat00 ! If you decide to get this properly diagnosed and addressed by your Dodge dealer and would like additional support, please do not hesitate to send us a private message!

Thanks,

Courtney
Dodge Cares
Thank you Courtney. I will try a reset tonight just in case it's simple. It's just difficult to get to a dealer and lose the car for a day. I was told (here anyways) that there will be an OTA update that will fix this, do you know if that's true? If so, then I'd prefer to just wait for that...
 

·
Registered
'21 DD Tow N Go / ‘17 Viper ACR
Joined
·
44 Posts
yes tried that like 10 times lol. bluetooth working fine for phone, but no car play which makes navigation and texts a problem.... built it nav is a pita compared to car play apple maps/google/waze and texts through car play allow it to be used hands free as we don't want to be texting while driving so this is an important feature.
did not say it was not important, I was just sharing! opinion is different from everyone. for me i like way better the built in nav rather than carplay.

hope your system get fixed soon!
 

·
Registered
Joined
·
515 Posts
did not say it was not important, I was just sharing! opinion is different from everyone. for me i like way better the built in nav rather than carplay.

hope your system get fixed soon!
Great news... I figured it was worth a shot and I disconnected Bluetooth and car play, tried a RE connect before trying a factory reset and all of a sudden it connected lol. Guess the 11th time was a charm.

And i understand, the factory nav does have some pluses, I’m not saying it’s not good or important... I like that it shows turns in the instrument cluster and I like that I can have nav and radio on half the screen at the same time.

I’m just saying it’s 100 times easier to enter an address or place quickly on maps on the phone or car play screen compared to the built in nav. I also noticed in this trial period of no car play that it doesn’t show traffic on a route like Apple Maps. Maybe for me it’s a bigger deal as I use it for work all day.

The other pluses I already mentioned , text and what’s app show on the screen and can be read or new messages sent hands free. Furthermore without car play if your connected to Bluetooth it silences the phone so you don’t even know you have messages. Again, I use it for work so that’s important for me as I have to respond quickly.

I’m very happy car play is back and hope it stays lol


Sent from my iPhone using Tapatalk
 
  • Like
Reactions: ZepGuy
121 - 140 of 184 Posts
Top