Dodge Durango Forum banner

501 - 520 of 626 Posts

·
Registered
'21 DD Tow N Go / ‘17 Viper ACR
Joined
·
197 Posts
2021 Durango Citadel Sirius radio says internet signal lost. Won't connect. Tried turning car off and on multiple times. Tried a soft reset holding volume and tune, came back on same issue. Sometimes it switches messages and says loading but the radio won't connect. This is a brand new car how can this be such a crappy radio.
did you try the resend radio signal?

try this:

 

·
Premium Member
Joined
·
461 Posts
2021 Durango Citadel Sirius radio says internet signal lost. Won't connect. Tried turning car off and on multiple times. Tried a soft reset holding volume and tune, came back on same issue. Sometimes it switches messages and says loading but the radio won't connect. This is a brand new car how can this be such a crappy radio.

If you are trying to listen to a stream only channel (like 703 or 704) you need to activate your 1 month trial of ATT 4 G data service. Now, how the heck do you do that??
At the top of your screen you will see a notification bell. Tap it and you will then see messages and one of them should be about the 4G/internet/wifi service. Tap that message and follow the directions to sign up with ATT for the 1 month free.

If you get that error (lost internet signal) on every channel then something else is wrong but I think it may be the stream only channels.
 

·
Registered
2021 Durango GTplus AWD
Joined
·
163 Posts
The VR is 100 percent useless with the new uconnect 5C.
Half the time it tells me phone is not ready which then requires a bluetooth disconnect and reconnect.
The other half the time it says, "pardon" no matter what I say or it cancels the session.
I have tried saying single words like YES or Okay since anything longer fails 100 percent of the time.
Single words only work 30 percent of the time which is terrible.
In my 2015 Jeep and Ram, the VR works outstanding so unlike what Uconnect said, it is not how I speak.
I also had my first crash/reboot the other day when i went from Nav to Home back to Nav.
Yesterday the screen was not functioning with touch but steering controls worked. I needed to reboot the unit which fixed it.
Agree about the VR. I tried using it a few times, and it kept saying pardon. I thought is was me, so had wife try it. Same thing.
 

·
Premium Member
Joined
·
461 Posts
I'll bet you a million dollars it does not come. I bet it doesn't even come July.
I will raise you 3 HellCats and 5 Trackhawks. LOL

One can only hope the update will be here in June. We do need to keep an eye on Jeep forums for when someone posts their GC L with the new Uconnect.
We can ask what version they have and compare it to ours. It would be an insane move for Stellantis/FCA to keep releasing models with a broken uconnect.
 

·
Registered
Joined
·
274 Posts
For the VR, just hold the button down longer. It will give you the Google Assistant or Siri off of your phone instead. Then it works just like you're at home. Even tho it is Android based, I find the Uconnect/Dodge assistant to be a bit challenged.
 

·
Registered
Joined
·
3 Posts
If you are trying to listen to a stream only channel (like 703 or 704) you need to activate your 1 month trial of ATT 4 G data service. Now, how the heck do you do that??
At the top of your screen you will see a notification bell. Tap it and you will then see messages and one of them should be about the 4G/internet/wifi service. Tap that message and follow the directions to sign up with ATT for the 1 month free.

If you get that error (lost internet signal) on every channel then something else is wrong but I think it may be the stream only channels.
Yup it's every channel. Never signed up for internet.
 

·
Registered
Joined
·
33 Posts
Map orientation set to "3D" in the settings. Reverts back to "N" (north always up) after accepting a destination.

Very annoying when you glance on the screen for the first turn and it's left when it should be right.
 

·
Registered
'21 DD Tow N Go / ‘17 Viper ACR
Joined
·
197 Posts
Map orientation set to "3D" in the settings. Reverts back to "N" (north always up) after accepting a destination.

Very annoying when you glance on the screen for the first turn and it's left when it should be right.
Yes I have this issue as well. I also don't like the way it autozoom. Not close enough in city driving. And the night mode uconnect nav contrast makes it hard to read.
 

·
Registered
Joined
·
269 Posts
Discussion Starter · #511 ·
Very strange issue I had this weekend... I was cruising on the highway, towing my camper, and I hit the off button for the air conditioning to listen for a rattle from my childs car seat. When I went to turn the air conditioning back on, the fan wouldn't turn on! NO AIR CONDITIONING! The back AC fan would run but nothing in the front. It freaked me out... I reset the Uconnect 5 and still nothing. I eventually pulled off the road, cycled off and on the car and the air conditioning started working again. I didn't try to replicate the issue. If someone here can try turning the fan completely off with the off button while driving, see if you can turn it back on by turning the fan knob up.
 

·
Registered
2021 Durango RT
Joined
·
55 Posts
For the VR, just hold the button down longer. It will give you the Google Assistant or Siri off of your phone instead. Then it works just like you're at home. Even tho it is Android based, I find the Uconnect/Dodge assistant to be a bit challenged.
I found this out too. Not sure why the Uconnect doesn't always connect my phone right away, but I have found if I hit the phone icon on the screen, and then place a call request, it seems to work better.
 

·
Registered
Joined
·
55 Posts
So I had the issue where the wound wouldn't play and the phone wouldn’t connect either, no even with the wire. I followed the reset instruction I believe on page 6 or 7 and didn’t work. So I actually realized under applecar play that I had several Uconnect profiles from my previous car and my wife’s car. So I deleted them all and re-synced the phone. No issues yet I’ll report if something happens.
 

·
Premium Member
Joined
·
461 Posts
I did some testing with the VR. If I reboot the system, the VR works fine until I turn off the Durango (such as getting to work) and when I restart it (after work) the VR is terrible.
I reboot the system and the VR is good for the ride home. Something is happening when the system sits idle for a while. I wonder if a process dies and when the system reboots it of course relaunches all processes correctly. Maybe a memory leak?

WHERE'S THE UPDATE?
 

·
Registered
2021 Durango GTplus AWD
Joined
·
163 Posts
Lmfao, everyone waiting for this update. I think we are lucky if we get it by December.
 

·
Registered
2014 Jeep Grand Cherokee Overland V6
Joined
·
2,049 Posts
Love my 8.4!




Couldn't resist!
 
501 - 520 of 626 Posts
Top