Dodge Durango Forum banner

221 - 240 of 412 Posts

·
Registered
'21 GT Plus Blacktop
Joined
·
3 Posts
I discovered the weather app isn't working either. Just loads forever then errors out. Not sure if it's related to my "services not activated" bug or not. In my '16 Charger the weather and gas prices were in their own app, but with the new system I'm not sure where those are supposed to show up. Are they in the weather app or tied into the Nav system and displayed there? Without a working system I don't know where to look. Also does anyone think a system reboot might fix some of my problems and how would I do that?
I had the same issue with my '21 GT Plus. I have to "sign into the network" each time I start the vehicle; it also affects the streaming channels in SXM 360L.

-tap the Notifications bell in the top bar
-tap "Android System: sign into the network"
-the AT&T sales pitch screen will load up
-tap the three dots in the upper right corner
-tap "use this network as-is"

Once I did all that, everything works fine, but again I have to do this EVERY TIME I start my DD. Also, if you accidentally tap something else and exit the AT&T screen any time before the last step, you're out of luck as there's no way to go back until you restart the system and the notification comes back. I found this by trial-and-error; there's nothing in the docs that tell you what to do, and I can't find any way to have the system use the built in network by default and stay signed in.
 

·
Registered
'21 DD Tow N Go / ‘17 Viper ACR
Joined
·
143 Posts
I discovered the weather app isn't working either. Just loads forever then errors out. Not sure if it's related to my "services not activated" bug or not. In my '16 Charger the weather and gas prices were in their own app, but with the new system I'm not sure where those are supposed to show up. Are they in the weather app or tied into the Nav system and displayed there? Without a working system I don't know where to look. Also does anyone think a system reboot might fix some of my problems and how would I do that?
mines work, but because I said so I will get the curse now
 

·
Registered
Joined
·
69 Posts
I Just got a 21 DDSRT and I have the single profile issue, but one other little thing I noticed, is that there is no option to skip Sirius channels like in the UConnect 4, even though I swear I read in the manual that it was possible...I still havent played around with the system enough yet to notice more...
 

·
Registered
Joined
·
21 Posts
Early in this forum someone mentioned that the Durango was getting a software upgrade soon. I think this was over a month ago already. Wondering if anyone has gotten an update for their system. I have not.
 

·
Registered
'21 DD Tow N Go / ‘17 Viper ACR
Joined
·
143 Posts
Early in this forum someone mentioned that the Durango was getting a software upgrade soon. I think this was over a month ago already. Wondering if anyone has gotten an update for their system. I have not.
My DD is at the dealer right now. Will ask when I pick it up later.
 

·
Registered
Joined
·
21 Posts
Awesome. Still working on my AA wireless. Also do not get the AA split screen it appears people are getting. Not sure if this requires a uconnect update or how to get that.
 

·
Registered
2021 Durango GTplus AWD
Joined
·
137 Posts
Awesome. Still working on my AA wireless. Also do not get the AA split screen it appears people are getting. Not sure if this requires a uconnect update or how to get that.
I'm guessing a Uconnect update. Android though sometimes strange, it only gets pushed server side for new features. Be careful what you wish for though. There's no way to disable split screen, which seems dumb, but sounds like something google would do.
 

·
Registered
2021 Tow n Go, 2020 Colorado ZR2
Joined
·
12 Posts
Early in this forum someone mentioned that the Durango was getting a software upgrade soon. I think this was over a month ago already. Wondering if anyone has gotten an update for their system. I have not.
I talked to uconnect today about my "services not activated", non-functioning weather app and non-functioning marketplace. Apparently they are all tied in to SiriusXM Guardian services somehow. They said there was a patch coming out in the 2nd quarter of the year but no garantees on timeline. Very frustrating for those of us with issues.
 

·
Registered
Joined
·
240 Posts
Discussion Starter · #231 ·
Jeff,

Curious what the dealer said about an update for the uconnect.
My dealer had not touched one of the new durangos when I brought mine in. I had to walk them through how to use it. Absolutely clueless and Dodge apparently didnt provide the techs with any training on the new system.
 

·
Premium Member
Joined
·
236 Posts
I have a 2021 RT and the green phone button on the wheel just brings up my call lists on the display. I was expecting the voice recognition would start like it does my my 2015 ram and 2015 JGC. I need to press the VR to make a call using voice recognition. The owners manual says "to start a call press the green phone button" but once would think the VR would kick in but it does not.
Also, the VR is not good and when it does not understand what you are saying it simply says, Pardon. Sometimes I can make a call using VR but text messaging fails every time.

What is your take on making a call, do you press the green button and the VR kicks in (or doesn't) or do you press the VR button and call that way?
 

·
Registered
Joined
·
211 Posts
I use Google Assistant on my phone to make calls.
 

·
Premium Member
Joined
·
236 Posts
I have a 2021 RT and the green phone button on the wheel just brings up my call lists on the display. I was expecting the voice recognition would start like it does my my 2015 ram and 2015 JGC. I need to press the VR to make a call using voice recognition. The owners manual says "to start a call press the green phone button" but once would think the VR would kick in but it does not.
Also, the VR is not good and when it does not understand what you are saying it simply says, Pardon. Sometimes I can make a call using VR but text messaging fails every time.

What is your take on making a call, do you press the green button and the VR kicks in (or doesn't) or do you press the VR button and call that way?
Ok per a Mopar video I found on using the UC5 it showed pressing the VR button to make a call. So I guess the green button is simply for answering or bringing up the phone info onto the screen where you can manually call/dial from.
 

·
Premium Member
Joined
·
236 Posts
New issue: Even though my phone is paired, when I use the VR button and say, call "name" , the NAV says your phone is not connected, please wait a few minutes and try again. Crazy thing is, I can get inbound calls and can use the keypad on the NAV to dial out. I just can't use the VR button as it keeps giving the "not connected" message. I unpaired and re-paired with no success.
Poking around the NAV I saw under messages ,"downloading" but it would not change and my contacts do not show up. I called Uconnect and they had me reset bluetooth on the NAV by holding the VR and green phone buttons for 30 seconds. Then open the door for 30 seconds and close it but it did not work. The typical next statement from Uconnect was, take it to the dealer. :mad:
I decided to poke around the NAV some more and turned off Android Auto (on nav and phone even though I was not using it) but still no go. I then decided to RESET the system, not Factory RESET just RESET (reboot). That fixed it and things worked fine after that. 😁I am sure it will happen again but at least I know how to fix it until a software update comes out.

Chrysler needs to listen to the end users and fix things based on our input.

Case in point, back in 2015 I discovered a bug in my 2015 Ram (Hemi) Sport with 8 speed trans. If you were accelerating past 65MPH, it would NEVER upshift into 8th (or 7th can't remember). The dealer said NPF and when I took them for a drive showing them, all they did was open a star case which went nowhere. Luckily, a Chrysler Transmission Engineer who watched forums PM'd me about the issue. With the info I gave him they got a test mule from another customer on the forum that joined the conversation and duplicated it. It took a couple of months for the update to be released and when I got it, it worked. I wish Chrysler would have software engineers/managers check out forums like this trans engineer did. Things could be fixed faster or at least acknowledged as a known issue instead of being told to go to the dealer to waste your day due to no fix or TSB being available.
 

·
Registered
'21 DD Tow N Go / ‘17 Viper ACR
Joined
·
143 Posts
@Vice-White issues with Uconnect5 seems to happen more with Android OS. I know some owner here said they have issue also with carplay, but the pie share is more on the android side. There's some glitchy behavior with carplay that seem to occur with a specific task. I am not a programmer or anything close but to my opinion, a lot of th glitches and bug happen to me when for instance I jump in the car and open spotify to play music before the uconnect boot and do all the logtask and after couples second it start by itself.

I don't know how to say that because I am french and my lack of english do not help me, but to me uconnect5 needs to be handle softly and polite. Mines working better since I am not rushing any command or source play etc.

Like when on carplay (android auto for you), I hate the fack that if I listen to XM radio or local FM radio, If i open a video on snapchat or youtube it automaticly change source to be able to play the sound through carplay.
 

·
Premium Member
Joined
·
236 Posts
@Vice-White issues with Uconnect5 seems to happen more with Android OS. I know some owner here said they have issue also with carplay, but the pie share is more on the android side. There's some glitchy behavior with carplay that seem to occur with a specific task. I am not a programmer or anything close but to my opinion, a lot of th glitches and bug happen to me when for instance I jump in the car and open spotify to play music before the uconnect boot and do all the logtask and after couples second it start by itself.

I don't know how to say that because I am french and my lack of english do not help me, but to me uconnect5 needs to be handle softly and polite. Mines working better since I am not rushing any command or source play etc.

Like when on carplay (android auto for you), I hate the fack that if I listen to XM radio or local FM radio, If i open a video on snapchat or youtube it automaticly change source to be able to play the sound through carplay.
Don't get me wrong, I love the system and know these are just bugs. I know they will get fixed but Chrysler could fix things sooner if they monitored the forums.
I am glad the system is fast which means Chrysler gave it a good CPU and memory. Now we just need an update.
 
221 - 240 of 412 Posts
Top