Dodge Durango Forum banner
2081 - 2100 of 2134 Posts

· Registered
Durango Hellcat
Joined
·
397 Posts
I believe this was posted before but for new people just seeing this.. this has dates when versions of Uconnect were supposed to be pushed out. If you’re not on R17.99 at this point I would reach out to DodgeCares and let them know. It’s been over a year since this software released.
Font Material property Parallel Screenshot Number
 

· Registered
Joined
·
749 Posts
I read somewhere that ANY codes stored in the system (maybe the entire car?) can cause this. Seems just stupid enough to be true. It might be worth doing a code scan to see what is floating around in there. Maybe stop by AutoZone or O'reillys or similar. They all offer free scans I think.
 

· Registered
Joined
·
162 Posts
I read somewhere that ANY codes stored in the system (maybe the entire car?) can cause this. Seems just stupid enough to be true. It might be worth doing a code scan to see what is floating around in there. Maybe stop by AutoZone or O'reillys or similar. They all offer free scans I think.
Interesting. I’ve got a scanner, I’ll take a look. Thanks for the tip.
 

· Registered
Joined
·
497 Posts
My 21 gt+ has the missing med setting. Just hi and low, but switch shows 3. It's seriously dumb of dodge to do this, but it doesn't bother me. Just another stupid thing though. This is my 1st and last dodge.
You can go and buy a Caddy and have the same issue my Aunt's 22 is still not fixed after 3 trips to the dealer...
 

· Registered
Durango Hellcat
Joined
·
397 Posts
Another day, another Uconnect error. Seriously, there's no rational explanation for why this is still so badly broken. View attachment 124674

@DodgeCares : Do I even bother bringing this thing to the dealer since it's on the latest release?
Still getting this one several times a day. I’ve been to the dealership a dozen times at least and they can’t do anything about it and it will be “fixed in an upcoming update” which doesn't appear to be happening anytime soon.
 

· Registered
Durango Hellcat
Joined
·
397 Posts
today's glitch was the radio asking me what Sirius package I wanted to order lol...so did the soft reboot and back to normal
Last night when I pulled into the garage I got a “Low Bat” banner that popped up on the bottom of the screen but then it went away. I tried to search but nothing is coming up. Now I don’t know if the error is real or not (because this Uconnect 5 system sucks) and I don’t know if it was a meaning the car battery, the fob battery or some other battery I don’t know about. 😞 🤦
 

· Premium Member
Joined
·
2,930 Posts
Last night when I pulled into the garage I got a “Low Bat” banner that popped up on the bottom of the screen but then it went away. I tried to search but nothing is coming up. Now I don’t know if the error is real or not (because this Uconnect 5 system sucks) and I don’t know if it was a meaning the car battery, the fob battery or some other battery I don’t know about. 😞 🤦
Where did ti show Low Bat in your IC or on UC5 ? If UC5 it was your phone battery warning.
 

· Premium Member
Joined
·
2,930 Posts
Thank you it does seem likely that it could be related to the phone. I just wish the alert wasn’t ambiguous so I wouldn’t have to guess.
Yeah, no warning on the Uconnect screen should have anything do with anything but the radio (as we all know) and the phone.
 

· Registered
Joined
·
162 Posts
This is new.

Used my key to unlock the Durango. Seat position automatically changed to match my profile. Got in, started it, UConnect remained at my wife’s profile (typical), and eventually switched to the profile selection screen (also typical, and representative of the ridiculously bad QA process - clearly NOBODY involved with this system has ever actually used it. There’s no situation where defaulting to this screen makes any sense.) Drove next door, shut the truck off, got out.

10 minutes later, got in, started it, and my profile automatically selected (typical that it happens after the second start with the different key). But this time, it dumped me to the settings screen.

That’s never happened before. Usually, it leaves me to the equally-useless-but-slightly-more-relevant profile selection screen.

How is it not illegal to knowingly sell something that’s broken, especially as it relates to vehicle controls?
 
2081 - 2100 of 2134 Posts
Top