Dodge Durango Forum banner

1 - 20 of 29 Posts

·
Registered
Joined
·
60 Posts
Discussion Starter #1
So after 3 days and numerous jump starts my DD with 1400 miles on it finally started and show this:


Anybody experience this?


Sent from my iPhone using Tapatalk
 

·
Super Moderator
Joined
·
12,862 Posts
why did it have to be jump started? could be a clue..
 

·
Registered
Joined
·
60 Posts
Discussion Starter #3
why did it have to be jump started? could be a clue..
I have.
I have no idea there is adequate voltage throughout the vehicle and all of the Electronics work 100% just won't turnover until a direct Battery jump is connected.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
132 Posts
Uh...warranty. Take it in ASAP.
 

·
Registered
Joined
·
60 Posts
Discussion Starter #5
Glad you said that. I called Dodge this morning and after 2hrs there response was no dealers in my area are accepting "tow-in" at this time. So I had to schedule an appointment for next week.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
1 Posts
Did you ever figure out what the problem was? My 2016 DD wouldn't start last week. Still under warranty so they towed it to the dealer, but the dealer cannot figure out the problem. They say it still won't start (this is day 6) and have no clue what's wrong...
 

·
Registered
Joined
·
11 Posts
I have.
I have no idea there is adequate voltage throughout the vehicle and all of the Electronics work 100% just won't turnover until a direct Battery jump is connected.


Sent from my iPhone using Tapatalk
did you ever find the problem, I’m having the exact same issue
 

·
Premium Member
Joined
·
3,763 Posts
Kimberly:
Welcome to DDN. Year, model, engine, and miles on your D please? Have you had the batter(ies) load tested to rule them out?

Don
 

·
Registered
Joined
·
11 Posts
Kimberly:
Welcome to DDN. Year, model, engine, and miles on your D please? Have you had the batter(ies) load tested to rule them out?

Don
2016 Dodge Durango Citadel 3.6 , 50k miles, got a new battery and alternator and new fuse box and still nothing,
 

·
Premium Member
Joined
·
3,763 Posts
If you can hook up a secondary power source, and it works, then it has to be problem in the chain between the battery and the starter. Some Durangos have had issues with relays in the starting circuitry.

Don
 

·
Registered
Joined
·
11 Posts
If you can hook up a secondary power source, and it works, then it has to be problem in the chain between the battery and the starter. Some Durangos have had issues with relays in the starting chain.

Don
What’s a secondary power source, and does that mean I need a new starter
 

·
Registered
2014 Jeep Grand Cherokee Overland V6
Joined
·
1,700 Posts
Secondary power source as in jumper cables to another battery.
 
  • Like
Reactions: Don Fox

·
Premium Member
Joined
·
3,763 Posts
If the starter is the culprit, not matter what you hook it to, it won't start. This is a weird deal!

Don
 

·
Premium Member
Joined
·
3,763 Posts
If the alternator is doing it's job, the car should have continued to run once the cables were removed. Hook the jumpers back up, let the jump vehicle idle for 5-7 minutes before you try to start it, Then, give it a whirl. IF it starts, leave the cables on, and observe. There might also be some kind of partial short drawing the battery down. Did they check for any electrical draw when the vehicle was off?
 
  • Like
Reactions: DuRonbo

·
Registered
2014 Jeep Grand Cherokee Overland V6
Joined
·
1,700 Posts
Someone had posted awhile back about a large fuse for the PDC being blown on a 3rd gen Durango. Wonder if this is similar?
 

·
Premium Member
Joined
·
3,763 Posts
Would not hurt to check, but you would think :oops::oops: that the dealer would have checked that........

Don
 

·
Registered
2014 Jeep Grand Cherokee Overland V6
Joined
·
1,700 Posts
Think he did the classic reversed jump cables when trying to start it with a dead battery! Seems to be a lot of that going on lately!
 
1 - 20 of 29 Posts
Top