Dodge Durango Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
122 Posts
Discussion Starter · #1 ·
Hi Durango Hive,

Our year+ old R/T seems to have a bug in the 8.4N system - the radio station presets just won't "stick".

Has anyone experienced this behavior, and if so how did you fix it?

Thanks.
 

·
Registered
Joined
·
29 Posts
My 15 RT does the same thing. I don't listen to the radio very often and have had to reset my presets about 3 times. So far I have no plans to take it in for that.
 

·
Super Moderator
Joined
·
13,001 Posts
yeah, make sure there is no way the other fob might be in/near the vehicle before going into a panic.. or go disable linking the fob to the presets.
 

·
Registered
Joined
·
176 Posts
From what I understand thus far in other forum posts, the radio presets are tied into the memory seat functions.
^^^ This ^^^

So, in the UConnect system, you can define whether or not the memory functions are tied to the key. I think you can also define whether or not those functions are automatically recalled by the key. To see if it is the key, with the car started, and in park, press the 1 (or 2) button on the driver's door (just under the arm rest). The display should says something to the effect of driver 1 memory recall (or driver 2). Once complete, check your settings. If they are not there, select the other memory setting and check again.
 

·
Super Moderator
Joined
·
13,001 Posts
My second fob is locked up in the safe and has never been used.
Try unchecking the boxes in uconnect anyway.. just to be sure..
 

·
Registered
Joined
·
122 Posts
Discussion Starter · #8 ·
^^^ This ^^^

So, in the UConnect system, you can define whether or not the memory functions are tied to the key. I think you can also define whether or not those functions are automatically recalled by the key. To see if it is the key, with the car started, and in park, press the 1 (or 2) button on the driver's door (just under the arm rest). The display should says something to the effect of driver 1 memory recall (or driver 2). Once complete, check your settings. If they are not there, select the other memory setting and check again.
OK, thank you - will try this process tonight and report back.
 

·
Registered
Joined
·
714 Posts
What about this issue for those of us that do not have the driver memory option?
The radio on my 15 SXT with the 8.4 will select am FM station at will when I switch from media to FM, most times it's not even a frequency where there is a station nearby.
I had set several presets with the XM stations I like, and today only 1 remained, and one other preset had been changed to the NBA station; all the reset were set to preview.

??
 

·
Super Moderator
Joined
·
13,001 Posts
Can't speak to this particular problem, but I can relate my experience with the 8.4AN that I have:

- if I leave it on SXM (which is my usual case) everything works fine.
- if I don't, I usually end up with some random FM channel (not station, though possibly a preset because I've never set any FM presets) selected when I next start up.

The software engineers at FCA/Harman need to learn a few things about real life.. :(

/rant
 

·
Registered
Joined
·
122 Posts
Discussion Starter · #11 ·
Welp, it was the memory setting - all the stations are set to #2, but my wife uses #1 (on the door) which doesn't have any stations pre-programmed.

D'oh!
 

·
Registered
Joined
·
176 Posts
Welp, it was the memory setting - all the stations are set to #2, but my wife uses #1 (on the door) which doesn't have any stations pre-programmed.

D'oh!
No worries... been there, done that. Now, set each memory with the same presets or personalize them so that when she gets in and presses 1, it recalls her settings, and if you get in and press 2, you'll have yours...
 

·
Registered
Joined
·
7 Posts
No worries... been there, done that. Now, set each memory with the same presets or personalize them so that when she gets in and presses 1, it recalls her settings, and if you get in and press 2, you'll have yours...
I was wondering if you could confirm something for me on the 2015 Durango......I have a 2014 Durango and have had an ongoing problem for 2+ years.......

If I enter my Durango after it has been sitting for <5 minutes and was left on memory 1 settings and i enter the car with keyfob that is tied to memory 2 settings......the seat and tilt move but the radio presents do not change to the settings for memory 2.

If I turn off the car exit and reenter right away and start the car again now the radio presets change.

If I remote start with keyfob 2 and enter the vehicle the presents change to memory 2 settings.

The dealership tells me it is working as designed....I disagree.....also of not...I also own a Jeep Cherokee with the same memory feature and the presents always change to the keyfob that enters the vehicle.

It seems to me that the issue is tired to whatever is sending the command to the radio is sending it before the radio is ready to receive the command based on my testing.
 
1 - 13 of 13 Posts
Top