Close
Login to Your Account
Dodge Durango Forum - Powered by vBulletin
Results 1 to 10 of 10

Thread: '99 Durango P0720 error code

  1. #1
    Junior Member
    Join Date
    Jul 2005
    Posts
    5
    Member #
    763

    '99 Durango P0720 error code

    I have a '99 Durango with 118,600 miles on it. Recently the check engine light has stayed on. I brought it in for service and they said it's giving a P0720 engine code. Now it appears they have diagnosed it wrong, they gave this:

    "CODE PO720 - TORQUE CONVERTER CLUTCH, NO RPM DROP AT LOCK UP"

    I was told buy some guys in the thread below that it was a generic error code and really all I need to do is replace the output speed sensor. Now I have just gotten back off the phone with the shop and they claimed they "went into the Dodge error codes" and this wasn't a generic code. He said he'd be shocked if this speed sensor fixed things. There are no real noticeable symptoms, perhaps a bit late shifting but not sure if I'm making that up.

    Thread on alt.autos.Dodge.trucks

  2. #2
    Senior Member DelDurango's Avatar
    Join Date
    Oct 2004
    Location
    Thornton, CO
    Posts
    772
    Member #
    321
    Liked
    4 times
    Vehicle
    99 Chilil Pepper Red Durango, tan leather interior
    Mods
    Mopar Performance intake, PPH Headers/custom exhaust, Superchips, MSD coil, helixed TB spacer
    I got this from an OBD II code website

    P0720 = Output Speed Sensor Circuit Malfunction

    goto :arrow: http://autorepair.about.com/cs/troub...l_obd_main.htm for any trouble codes you get
    Dan - student at Front Range Community College, Westminster, CO. 99 D 4x4 5.9 / 4 spd a/t, CPR, leather interior helixed TB spacer, MSD #8228 coil, homemade CAI, PPH headers/full custom dual exhaust, Superchips.

  3. #3
    Junior Member
    Join Date
    Jul 2005
    Posts
    5
    Member #
    763
    Strange? I'm not sure why they have such a differing description of that code.

    Thanks for the link!

  4. #4
    Senior Member DelDurango's Avatar
    Join Date
    Oct 2004
    Location
    Thornton, CO
    Posts
    772
    Member #
    321
    Liked
    4 times
    Vehicle
    99 Chilil Pepper Red Durango, tan leather interior
    Mods
    Mopar Performance intake, PPH Headers/custom exhaust, Superchips, MSD coil, helixed TB spacer
    MY PLEASURE it was given to me. so I figured it best to pass it on.
    Dan - student at Front Range Community College, Westminster, CO. 99 D 4x4 5.9 / 4 spd a/t, CPR, leather interior helixed TB spacer, MSD #8228 coil, homemade CAI, PPH headers/full custom dual exhaust, Superchips.

  5. #5
    Senior Member
    Join Date
    Jun 2004
    Location
    Northern CA-Bay Area
    Posts
    457
    Member #
    28
    I had that exact same code a couple of months ago-it's the output speed sensor on the trannie. I got the code definition from my FSM. I replaced the sensor and all was fine. The only symptoms I noticed was the trannie wanted to start in second instaed of first. It'd stumble and lurch. I have a 98 so I'm not sure if the p/n is the same for a 99 although I'd imagine that it'd be, but double check first. Here's the part number off the part-04800879 and the one I got was made by Standard Automotive with a P/N of SC104. The full P/N of 04800879 is stamped on the new part also. It's located on the left side of the trannie, can't really miss it. It has a two prong connector and you need a 1in dia socket to get at it. When you loosen it, have the other one right in hand and a small pan underneath to catch the trannie fluid that'll come out. Just slap the new in as fast as you can and you won't lose too much trannie fluid. Recheck the fluid after you're all done and top off as needed. Mind you this *not* the rear wheel speed sensor on top of the differential-this is mounted on the trannie.
    98 5.9 Durango SLT+ PT 4x4
    MPPCM
    IP STG II Intake
    Fastman 52mm
    Taylor 8mm Wires
    NGK PLugs
    MP PPH Headers
    3.92 Gears
    Detroit Locker
    Upgraded Balljoints

  6. #6
    Junior Member
    Join Date
    Jul 2005
    Posts
    5
    Member #
    763
    Well I think I'll hit the auto parts store, have them verify the code and put the part in myself.

  7. #7
    Junior Member
    Join Date
    Jul 2005
    Posts
    5
    Member #
    763

    fixed

    Last night went to an auto parts store. I tried to get them to verify the trouble code but their machine was broken. I bought the output speed sensor and installed it just as Dadditruck said. Thanks for the description.

    Check engine light is now off and the truck seems to be shifting smoother than before. Hopefully this fixes my problem.

    I couldn't have done it without you guys, thanks!!

  8. #8
    Senior Member Silver Ghost's Avatar
    Join Date
    May 2004
    Location
    Upstate NY
    Posts
    2,049
    Member #
    5
    Wow! Another happy Forum Poster
    Sure beats having major transmission work done, doesn't it.
    The DOC is happy to help.

    Joe
    Joe 2004 RAM2500 SLT Bright Silver Metallic, QC, SB, Hemi, Line-X, TonneauMaster, RB-1 Nav Radio

  9. #9
    Junior Member
    Join Date
    Jul 2005
    Posts
    5
    Member #
    763
    You have no idea! My wife and I were actually discussing what we'd do if it needed major transmission work. Would we sell it, would we keep it, what it was worth? I'm so glad I checked here!!

  10. #10
    Senior Member QuickSilver's Avatar
    Join Date
    Sep 2004
    Location
    Suffolk VA
    Posts
    177
    Member #
    75
    So, while you're enjoying the sweet smell of success, go ahead and join the club! You have already seen how friendly and helpful these folks are? you might be interested in some of the Get-Togethers in your region, or the upcoming tour of the Durango plant this fall.
    Terry
    1st Generation: '00 Durango 5.9 SLT (Platinum)
    2nd Generation: '05 Durango Hemi SLT 4x4 (White)

Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Error code help p 0157
    By HEMI x 3 in forum Durango Discussions 2004-09
    Replies: 8
    Last Post: 05-11-2008, 06:28 PM
  2. Error Code P0700
    By JohnS in forum Durango Discussions 1998-03
    Replies: 2
    Last Post: 04-11-2008, 05:41 PM
  3. No Bus error code.
    By rbivins in forum Durango Discussions 1998-03
    Replies: 20
    Last Post: 07-01-2006, 04:10 PM
  4. 0455 Error Code
    By 98MachZ in forum Durango Discussions 1998-03
    Replies: 1
    Last Post: 04-12-2006, 11:17 AM
  5. When the Check Engine Light shows and the code is P0720?
    By Uncle Frodo in forum Durango Discussions 1998-03
    Replies: 0
    Last Post: 01-25-2006, 05:48 PM

Search tags for this page

1998 dodge durango p0720

,

98 durango p0720

,

99 dodge durango p0720

,

99 durango p0720

,

dodge durango error code p0720

,
p0720 98 durango
,

p0720 dodge durango

,

p0720 durango

Click on a term to search for related topics.